BasicDSP Namespace

[image]

BasicDSP - Digital Signal Processing Library
BasicDSP Namespace
Send Feedback
BasicDSP is a free library of elementary digital signal processing routines that can be exploited in any .NET application. It has been developed primarily for educational purposes, to allow students to build simple signal processing applications in Visual Basic. However it may have wider use in other applications where speed of processing is not critical.

Classes

Class | Description
BasicDSPException | Provides mechanism for raising errors within BasicDSP
Complex | The Complex class supports complex number variables and complex arithmetic.
ComplexWaveform | Supports waveform of complex numbers.
DFT | Library functions for Discrete Fourier Transforms.
Filter | Library functions to support creation and application of filters.
Graph | Supports simple graphs using the ZedGraph charting library
LPC | Library functions for Linear Prediction modelling
LTISystem | Class to support creation and application of Linear System models
LTISystemChain | Supports chain of linear systems
Roots |
Sample | Library functions to sample from various signal sources
Signal | Support for sampled waveforms quantised into short integers
Spectrum | Supports complex spectrum array
Utility | Library functions to support miscellaneous utility operations
Wave | Supports generic waveforms consisting of an array of samples at a given sampling rate.
WaveComplex | Supports sampled waveforms with complex values
WaveDouble | Supports waveforms of double precision values
Waveform | Supports waveforms containing floating-point samples
WaveShort | Supports waveforms with short integer samples
Window | Library functions to support generation and application of signal windows

Send comments on this topic to m.huckvale@ucl.ac.uk

(c) 2009 Mark Huckvale University College London


BasicDSPException Class

[image]

BasicDSP - Digital Signal Processing Library
BasicDSPException Class
Members See Also Send Feedback
Provides mechanism for raising errors within BasicDSP

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class BasicDSPException : Exception
Visual Basic (Declaration)
Public Class BasicDSPException _
    Inherits Exception
Visual C++
public ref class BasicDSPException : public Exception

Remarks

Inheritance Hierarchy

System..::.Object
System..::.Exception
BasicDSP..::.BasicDSPException

See Also

BasicDSPException Members
BasicDSP Namespace


BasicDSPException Members

[image] [image]

BasicDSP - Digital Signal Processing Library
BasicDSPException Members
BasicDSPException Class Constructors Methods See Also Send Feedback

The BasicDSPException type exposes the following members.

Constructors

Name | Description
BasicDSPException | Creates a new exception

Methods

Name | Description
ToString | Convert exception to informative message (Overrides Exception..::.ToString()()().)

See Also

BasicDSPException Class


BasicDSPException Constructor

[image]

BasicDSP - Digital Signal Processing Library
BasicDSPException Constructor
BasicDSPException Class See Also Send Feedback
Creates a new exception

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public BasicDSPException(
    string Message
)
Visual Basic (Declaration)
Public Sub New ( _
    Message As String _
)
Visual C++
public:
BasicDSPException(
    String^ Message
)

Parameters

Message
Type: System..::.String
Exception message

Remarks

See Also

BasicDSPException Class


BasicDSPException Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
BasicDSPException Methods
BasicDSPException Class See Also Send Feedback

The BasicDSPException type exposes the following members.

Methods

Name | Description
ToString | Convert exception to informative message (Overrides Exception..::.ToString()()().)

See Also

BasicDSPException Class


ToString Method

[image]

BasicDSP - Digital Signal Processing Library
BasicDSPException..::.ToString Method
BasicDSPException Class See Also Send Feedback
Convert exception to informative message

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Message string

Implements

_Exception..::.ToString()()()

Remarks

See Also

BasicDSPException Class


Complex Class

[image]

BasicDSP - Digital Signal Processing Library
Complex Class
Members See Also Send Feedback
The Complex class supports complex number variables and complex arithmetic.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Complex
Visual Basic (Declaration)
Public Class Complex
Visual C++
public ref class Complex

Remarks

Examples

Example use is shown below.
CopyC#
Sub RealQuadRoot(ByVal a As Double, ByVal b As Double, ByVal c As Double, ByRef x1 As Double, ByRef x2 As Double)
    x1 = (-b + Math.Sqrt(b * b - 4 * a * c)) / (2 * a)
    x2 = (-b - Math.Sqrt(b * b - 4 * a * c)) / (2 * a)
End Sub
Sub ComplexQuadRoot(ByVal a As Double, ByVal b As Double, ByVal c As Double, ByRef x1 As Complex, ByRef x2 As Complex)
    x1 = (-b + Complex.sqrt(b * b - 4 * a * c)) / (2 * a)
    x2 = (-b - Complex.sqrt(b * b - 4 * a * c)) / (2 * a)
End Sub
Sub Main()
    Dim a As New Complex(1, 2)
    Dim b As New Complex(3, 4)
    Dim c As New Complex()
    c = a + b
    Console.WriteLine("a=" & a.ToString() & " b=" & b.ToString & " a+b=" & c.ToString)
    c = a - b
    Console.WriteLine("a=" & a.ToString() & " b=" & b.ToString & " a-b=" & c.ToString)
    c = a * b
    Console.WriteLine("a=" & a.ToString() & " b=" & b.ToString & " a*b=" & c.ToString)
    c = a / b
    Console.WriteLine("a=" & a.ToString() & " b=" & b.ToString & " a/b=" & c.ToString)
    Console.WriteLine("c=" & c.ToString() & " mag(c)=" & c.Mag & " arg(c)=" & c.Arg)
    c = BasicDSP.Complex.exp(a)
    Console.WriteLine("a=" & a.ToString() & " exp(a)=" & c.ToString())
    b = BasicDSP.Complex.sqrt(a)
    c = b * b
    Console.WriteLine("a=" & a.ToString() & " sqrt(a)=" & b.ToString() & " c=" & c.ToString())
    a = b
    Console.WriteLine("a=" & a.ToString())
    Dim r1 As Double, r2 As Double
    Dim c1 As New Complex(0)
    Dim c2 As New Complex(0)
    RealQuadRoot(3, 9, 6, r1, r2)
    Console.WriteLine("r1=" & r1 & " r2=" & r2)
    ComplexQuadRoot(3, 9, 6, c1, c2)
    Console.WriteLine("c1=" & c1.ToString() & " c2=" & c2.ToString())
    Console.ReadLine()
End Sub

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Complex

See Also

Complex Members


Complex Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Complex Members
Complex Class Constructors Methods Properties See Also Send Feedback

The Complex type exposes the following members.

Constructors

Name | Description
Complex | Overloaded.

Methods

Name | Description
Exp | Calculates exponential of complex value
Sqrt | Calculate square root of complex value
ToString | Converts complex value to string (Overrides Object..::.ToString()()().)

Operators

Name | Description
Addition | Adds two complex values.
Division | Divides two complex values.
Implicit | Casts real value to complex value
Multiply | Multiplies two complex values.
Subtraction | Subtracts two complex values.

Properties

Name | Description
Arg | Gets argument of complex value
Imag | Gets or sets the imaginary part of complex variable
Mag | Gets magnitude of complex value
Real | Gets or sets the real part of a complex variable

See Also

Complex Class


Complex Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
Complex Constructor
Complex Class See Also Send Feedback

Overload List

Name | Description
Complex()()() | Creates complex number set to zero.
Complex(Complex) | Creates a complex number set to the complex value given.
Complex(Double) | Creates complex number set to the real value given.
Complex(Double, Double) | Creates a complex number set to the real and imaginary values given.

See Also

Complex Class
Complex Members


Complex Constructor

[image]

BasicDSP - Digital Signal Processing Library
Complex Constructor
Complex Class See Also Send Feedback
Creates complex number set to zero.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Complex()

Remarks

See Also

Complex Class
Complex Overload


Complex Constructor (Complex)

[image]

BasicDSP - Digital Signal Processing Library
Complex Constructor (Complex)
Complex Class See Also Send Feedback
Creates a complex number set to the complex value given.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex(
    Complex cval
)
Visual Basic (Declaration)
Public Sub New ( _
    cval As Complex _
)
Visual C++
public:
Complex(
    Complex^ cval
)

Parameters

cval
Type: BasicDSP..::.Complex
Complex value

Remarks

See Also

Complex Class
Complex Overload


Complex Constructor (Double)

[image]

BasicDSP - Digital Signal Processing Library
Complex Constructor (Double)
Complex Class See Also Send Feedback
Creates complex number set to the real value given.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex(
    double rval
)
Visual Basic (Declaration)
Public Sub New ( _
    rval As Double _
)
Visual C++
public:
Complex(
    double rval
)

Parameters

rval
Type: System..::.Double
Given real value

Remarks

See Also

Complex Class
Complex Overload


Complex Constructor (Double, Double)

[image]

BasicDSP - Digital Signal Processing Library
Complex Constructor (Double, Double)
Complex Class See Also Send Feedback
Creates a complex number set to the real and imaginary values given.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex(
    double rval,
    double ival
)
Visual Basic (Declaration)
Public Sub New ( _
    rval As Double, _
    ival As Double _
)
Visual C++
public:
Complex(
    double rval,
    double ival
)

Parameters

rval
Type: System..::.Double
Real value
ival
Type: System..::.Double
Imaginary value

Remarks

See Also

Complex Class
Complex Overload


Complex Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Complex Methods
Complex Class See Also Send Feedback

The Complex type exposes the following members.

Methods

Name | Description
Exp | Calculates exponential of complex value
Sqrt | Calculate square root of complex value
ToString | Converts complex value to string (Overrides Object..::.ToString()()().)

Operators

Name | Description
Addition | Adds two complex values.
Division | Divides two complex values.
Implicit | Casts real value to complex value
Multiply | Multiplies two complex values.
Subtraction | Subtracts two complex values.

See Also

Complex Class


Addition Operator

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Addition Operator
Complex Class See Also Send Feedback
Adds two complex values.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex operator +(
    Complex cval1,
    Complex cval2
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    cval1 As Complex, _
    cval2 As Complex _
) As Complex
Visual C++
public:
static Complex^ operator +(
    Complex^ cval1,
    Complex^ cval2
)

Parameters

cval1
Type: BasicDSP..::.Complex
Complex value
cval2
Type: BasicDSP..::.Complex
Complex value

Return Value

Complex sum

Remarks

See Also

Complex Class


Division Operator

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Division Operator
Complex Class See Also Send Feedback
Divides two complex values.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex operator /(
    Complex cval1,
    Complex cval2
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    cval1 As Complex, _
    cval2 As Complex _
) As Complex
Visual C++
public:
static Complex^ operator /(
    Complex^ cval1,
    Complex^ cval2
)

Parameters

cval1
Type: BasicDSP..::.Complex
Complex numerator
cval2
Type: BasicDSP..::.Complex
Complex denominator

Return Value

Complex fraction

Remarks

Returns 0 for zero denominator

See Also

Complex Class


Exp Method

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Exp Method
Complex Class See Also Send Feedback
Calculates exponential of complex value

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex Exp(
    Complex cval
)
Visual Basic (Declaration)
Public Shared Function Exp ( _
    cval As Complex _
) As Complex
Visual C++
public:
static Complex^ Exp(
    Complex^ cval
)

Parameters

cval
Type: BasicDSP..::.Complex
Complex value

Return Value

Complex exponential

Remarks

See Also

Complex Class


Implicit Operator

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Implicit Operator
Complex Class See Also Send Feedback
Casts real value to complex value

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static implicit operator Complex (
    double val
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    val As Double _
) As Complex
Visual C++
static implicit operator Complex^ (
    double val
)

Parameters

val
Type: System..::.Double
Real value

Return Value

Complex value

Remarks

See Also

Complex Class


Multiply Operator

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Multiply Operator
Complex Class See Also Send Feedback
Multiplies two complex values.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex operator *(
    Complex cval1,
    Complex cval2
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    cval1 As Complex, _
    cval2 As Complex _
) As Complex
Visual C++
public:
static Complex^ operator *(
    Complex^ cval1,
    Complex^ cval2
)

Parameters

cval1
Type: BasicDSP..::.Complex
Complex value
cval2
Type: BasicDSP..::.Complex
Complex value

Return Value

Complex product

Remarks

See Also

Complex Class


Sqrt Method

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Sqrt Method
Complex Class See Also Send Feedback
Calculate square root of complex value

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex Sqrt(
    Complex cval
)
Visual Basic (Declaration)
Public Shared Function Sqrt ( _
    cval As Complex _
) As Complex
Visual C++
public:
static Complex^ Sqrt(
    Complex^ cval
)

Parameters

cval
Type: BasicDSP..::.Complex
Complex value

Return Value

Square root

Remarks

See Also

Complex Class


Subtraction Operator

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Subtraction Operator
Complex Class See Also Send Feedback
Subtracts two complex values.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex operator -(
    Complex cval1,
    Complex cval2
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    cval1 As Complex, _
    cval2 As Complex _
) As Complex
Visual C++
public:
static Complex^ operator -(
    Complex^ cval1,
    Complex^ cval2
)

Parameters

cval1
Type: BasicDSP..::.Complex
Complex value
cval2
Type: BasicDSP..::.Complex
Complex value

Return Value

Complex difference

Remarks

See Also

Complex Class


ToString Method

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.ToString Method
Complex Class See Also Send Feedback
Converts complex value to string

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String expression of complex value

Remarks

See Also

Complex Class


Complex Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
Complex Properties
Complex Class See Also Send Feedback

The Complex type exposes the following members.

Properties

Name | Description
Arg | Gets argument of complex value
Imag | Gets or sets the imaginary part of complex variable
Mag | Gets magnitude of complex value
Real | Gets or sets the real part of a complex variable

See Also

Complex Class


Arg Property

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Arg Property
Complex Class See Also Send Feedback
Gets argument of complex value

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double Arg { get; }
Visual Basic (Declaration)
Public ReadOnly Property Arg As Double
Visual C++
public:
property double Arg {
    double get ();
}

Field Value

Argument

Return Value

Real argument

Remarks

Argument in Radians

See Also

Complex Class


Imag Property

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Imag Property
Complex Class See Also Send Feedback
Gets or sets the imaginary part of complex variable

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double Imag { get; set; }
Visual Basic (Declaration)
Public Property Imag As Double
Visual C++
public:
property double Imag {
    double get ();
    void set (double value);
}

Field Value

Return Value

Imaginary part

Remarks

See Also

Complex Class


Mag Property

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Mag Property
Complex Class See Also Send Feedback
Gets magnitude of complex value

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double Mag { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mag As Double
Visual C++
public:
property double Mag {
    double get ();
}

Field Value

Magnitude

Return Value

Real magnitude

Remarks

See Also

Complex Class


Real Property

[image]

BasicDSP - Digital Signal Processing Library
Complex..::.Real Property
Complex Class See Also Send Feedback
Gets or sets the real part of a complex variable

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double Real { get; set; }
Visual Basic (Declaration)
Public Property Real As Double
Visual C++
public:
property double Real {
    double get ();
    void set (double value);
}

Field Value

Return Value

Real part

Remarks

See Also

Complex Class


ComplexWaveform Class

[image]

BasicDSP - Digital Signal Processing Library
ComplexWaveform Class
Members See Also Send Feedback
Supports waveform of complex numbers.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class ComplexWaveform : WaveComplex
Visual Basic (Declaration)
Public Class ComplexWaveform _
    Inherits WaveComplex
Visual C++
public ref class ComplexWaveform : public WaveComplex

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveComplex
BasicDSP..::.ComplexWaveform

See Also

ComplexWaveform Members


ComplexWaveform Members

[image] [image]

BasicDSP - Digital Signal Processing Library
ComplexWaveform Members
ComplexWaveform Class Constructors Methods Fields Properties See Also Send Feedback

The ComplexWaveform type exposes the following members.

Constructors

Name | Description
ComplexWaveform | Creates complex waveform.

Methods

Name | Description
Add | Adds a single complex sample to the end of the waveform (Inherited from WaveComplex.)
Arg | Convert argument of complex waveform to waveform (Inherited from WaveComplex.)
Cut | Cuts a region out of a ComplexWaveform
Imag | Convert imaginary part of complex waveform to waveform (Inherited from WaveComplex.)
Mag | Convert magnitude of complex waveform to waveform (Inherited from WaveComplex.)
Real | Convert real part of complex waveform to waveform (Inherited from WaveComplex.)

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of complex samples (Inherited from WaveComplex.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets samples by index (Inherited from WaveComplex.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

ComplexWaveform Class


ComplexWaveform Constructor

[image]

BasicDSP - Digital Signal Processing Library
ComplexWaveform Constructor
ComplexWaveform Class See Also Send Feedback
Creates complex waveform.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public ComplexWaveform(
    int length,
    double rate
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double _
)
Visual C++
public:
ComplexWaveform(
    int length,
    double rate
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate

Remarks

See Also

ComplexWaveform Class


ComplexWaveform Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
ComplexWaveform Fields
ComplexWaveform Class See Also Send Feedback

The ComplexWaveform type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of complex samples (Inherited from WaveComplex.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

See Also

ComplexWaveform Class


ComplexWaveform Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
ComplexWaveform Methods
ComplexWaveform Class See Also Send Feedback

The ComplexWaveform type exposes the following members.

Methods

Name | Description
Add | Adds a single complex sample to the end of the waveform (Inherited from WaveComplex.)
Arg | Convert argument of complex waveform to waveform (Inherited from WaveComplex.)
Cut | Cuts a region out of a ComplexWaveform
Imag | Convert imaginary part of complex waveform to waveform (Inherited from WaveComplex.)
Mag | Convert magnitude of complex waveform to waveform (Inherited from WaveComplex.)
Real | Convert real part of complex waveform to waveform (Inherited from WaveComplex.)

See Also

ComplexWaveform Class


Cut Method

[image]

BasicDSP - Digital Signal Processing Library
ComplexWaveform..::.Cut Method
ComplexWaveform Class See Also Send Feedback
Cuts a region out of a ComplexWaveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public ComplexWaveform Cut(
    int first,
    int len
)
Visual Basic (Declaration)
Public Function Cut ( _
    first As Integer, _
    len As Integer _
) As ComplexWaveform
Visual C++
public:
ComplexWaveform^ Cut(
    int first,
    int len
)

Parameters

first
Type: System..::.Int32
Starting index
len
Type: System..::.Int32
Number of samples

Return Value

Cut portion

Remarks

See Also

ComplexWaveform Class


ComplexWaveform Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
ComplexWaveform Properties
ComplexWaveform Class See Also Send Feedback

The ComplexWaveform type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets samples by index (Inherited from WaveComplex.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

ComplexWaveform Class


DFT Class

[image]

BasicDSP - Digital Signal Processing Library
DFT Class
Members See Also Send Feedback
Library functions for Discrete Fourier Transforms.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class DFT
Visual Basic (Declaration)
Public Class DFT
Visual C++
public ref class DFT

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.DFT

See Also

DFT Members


DFT Members

[image] [image]

BasicDSP - Digital Signal Processing Library
DFT Members
DFT Class Constructors Methods See Also Send Feedback

The DFT type exposes the following members.

Constructors

Name | Description
DFT | Initializes a new instance of the DFT class

Methods

Name | Description
ComplexDFT | Computes complex discrete Fourier transform
ComplexFFT | Comput complex fast discrete Fourier transform
ComplexIDFT | Computes complex inverse discrete Fourier transform
ComplexIFFT | Compute complex fast inverse discrete Fourier transform

See Also

DFT Class


DFT Constructor

[image]

BasicDSP - Digital Signal Processing Library
DFT Constructor
DFT Class See Also Send Feedback
Initializes a new instance of the DFT class

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public DFT()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DFT()

See Also

DFT Class


DFT Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
DFT Methods
DFT Class See Also Send Feedback

The DFT type exposes the following members.

Methods

Name | Description
ComplexDFT | Computes complex discrete Fourier transform
ComplexFFT | Comput complex fast discrete Fourier transform
ComplexIDFT | Computes complex inverse discrete Fourier transform
ComplexIFFT | Compute complex fast inverse discrete Fourier transform

See Also

DFT Class


ComplexDFT Method

[image]

BasicDSP - Digital Signal Processing Library
DFT..::.ComplexDFT Method
DFT Class See Also Send Feedback
Computes complex discrete Fourier transform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Spectrum ComplexDFT(
    ComplexWaveform x
)
Visual Basic (Declaration)
Public Shared Function ComplexDFT ( _
    x As ComplexWaveform _
) As Spectrum
Visual C++
public:
static Spectrum^ ComplexDFT(
    ComplexWaveform^ x
)

Parameters

x
Type: BasicDSP..::.ComplexWaveform
Complex waveform

Return Value

Complex spectrum

Remarks

See Also

DFT Class


ComplexFFT Method

[image]

BasicDSP - Digital Signal Processing Library
DFT..::.ComplexFFT Method
DFT Class See Also Send Feedback
Comput complex fast discrete Fourier transform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Spectrum ComplexFFT(
    ref ComplexWaveform x
)
Visual Basic (Declaration)
Public Shared Function ComplexFFT ( _
    ByRef x As ComplexWaveform _
) As Spectrum
Visual C++
public:
static Spectrum^ ComplexFFT(
    ComplexWaveform^% x
)

Parameters

x
Type: BasicDSP..::.ComplexWaveform %
Complex waveform

Return Value

Complex spectrum

Remarks

Length of input should be integer power of 2

See Also

DFT Class


ComplexIDFT Method

[image]

BasicDSP - Digital Signal Processing Library
DFT..::.ComplexIDFT Method
DFT Class See Also Send Feedback
Computes complex inverse discrete Fourier transform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static ComplexWaveform ComplexIDFT(
    Spectrum s
)
Visual Basic (Declaration)
Public Shared Function ComplexIDFT ( _
    s As Spectrum _
) As ComplexWaveform
Visual C++
public:
static ComplexWaveform^ ComplexIDFT(
    Spectrum^ s
)

Parameters

s
Type: BasicDSP..::.Spectrum
Complex spectrum

Return Value

Complex waveform

Remarks

See Also

DFT Class


ComplexIFFT Method

[image]

BasicDSP - Digital Signal Processing Library
DFT..::.ComplexIFFT Method
DFT Class See Also Send Feedback
Compute complex fast inverse discrete Fourier transform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static ComplexWaveform ComplexIFFT(
    ref Spectrum s
)
Visual Basic (Declaration)
Public Shared Function ComplexIFFT ( _
    ByRef s As Spectrum _
) As ComplexWaveform
Visual C++
public:
static ComplexWaveform^ ComplexIFFT(
    Spectrum^% s
)

Parameters

s
Type: BasicDSP..::.Spectrum %
Complex spectrum

Return Value

Complex waveform

Remarks

Length of input should be integer power of 2

See Also

DFT Class


Filter Class

[image]

BasicDSP - Digital Signal Processing Library
Filter Class
Members See Also Send Feedback
Library functions to support creation and application of filters.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Filter
Visual Basic (Declaration)
Public Class Filter
Visual C++
public ref class Filter

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Filter

See Also

Filter Members


Filter Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Filter Members
Filter Class Constructors Methods See Also Send Feedback

The Filter type exposes the following members.

Constructors

Name | Description
Filter | Initializes a new instance of the Filter class

Methods

Name | Description
ButterworthBandPass | Design Butterworth band-pass recursive filter
ButterworthHighPass | Design Butterworth high-pass recursive filter
ButterworthLowPass | Design Butterworth low-pass recursive filter
ButterworthPoles | Calculates pole positions for Butterworth design low-pass filter
Convolve | Overloaded.
NRBandPass | Design non-recursive band-pass filter
NRBandPassTransform | Transform non-recursive low-pass filter to band-pass
NRHighPass | Design non-recursive high-pass filter
NRHighPassTransform | Transform non-recursive low-pass filter to high-pass
NRLowPass | Design non-recursive low-pass filter.
Resonator | Builds a linear system for a resonator

See Also

Filter Class


Filter Constructor

[image]

BasicDSP - Digital Signal Processing Library
Filter Constructor
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Filter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Filter()

See Also

Filter Class


Filter Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

Name | Description
ButterworthBandPass | Design Butterworth band-pass recursive filter
ButterworthHighPass | Design Butterworth high-pass recursive filter
ButterworthLowPass | Design Butterworth low-pass recursive filter
ButterworthPoles | Calculates pole positions for Butterworth design low-pass filter
Convolve | Overloaded.
NRBandPass | Design non-recursive band-pass filter
NRBandPassTransform | Transform non-recursive low-pass filter to band-pass
NRHighPass | Design non-recursive high-pass filter
NRHighPassTransform | Transform non-recursive low-pass filter to high-pass
NRLowPass | Design non-recursive low-pass filter.
Resonator | Builds a linear system for a resonator

See Also

Filter Class


ButterworthBandPass Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.ButterworthBandPass Method
Filter Class See Also Send Feedback
Design Butterworth band-pass recursive filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystemChain ButterworthBandPass(
    double lofreq,
    double hifreq,
    int nsection
)
Visual Basic (Declaration)
Public Shared Function ButterworthBandPass ( _
    lofreq As Double, _
    hifreq As Double, _
    nsection As Integer _
) As LTISystemChain
Visual C++
public:
static LTISystemChain^ ButterworthBandPass(
    double lofreq,
    double hifreq,
    int nsection
)

Parameters

lofreq
Type: System..::.Double
Normalised lower cut-off frequency (0-0.5)
hifreq
Type: System..::.Double
Normalised upper cut-off frequency (0-0.5)
nsection
Type: System..::.Int32
Number of second order sections in filter

Return Value

Butterworth band-pass filter as linear system

Remarks

See Also

Filter Class


ButterworthHighPass Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.ButterworthHighPass Method
Filter Class See Also Send Feedback
Design Butterworth high-pass recursive filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystemChain ButterworthHighPass(
    double freq,
    int nsection
)
Visual Basic (Declaration)
Public Shared Function ButterworthHighPass ( _
    freq As Double, _
    nsection As Integer _
) As LTISystemChain
Visual C++
public:
static LTISystemChain^ ButterworthHighPass(
    double freq,
    int nsection
)

Parameters

freq
Type: System..::.Double
Normalised cut-off frequency (0-0.5)
nsection
Type: System..::.Int32
Number of second order sections in filter

Return Value

Butterworth high-pass filter as linear system

Remarks

See Also

Filter Class


ButterworthLowPass Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.ButterworthLowPass Method
Filter Class See Also Send Feedback
Design Butterworth low-pass recursive filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystemChain ButterworthLowPass(
    double freq,
    int nsection
)
Visual Basic (Declaration)
Public Shared Function ButterworthLowPass ( _
    freq As Double, _
    nsection As Integer _
) As LTISystemChain
Visual C++
public:
static LTISystemChain^ ButterworthLowPass(
    double freq,
    int nsection
)

Parameters

freq
Type: System..::.Double
Normalised cut-off frequency (0-0.5)
nsection
Type: System..::.Int32
Number of second order sections in filter

Return Value

Butterworth low-pass filter as linear system

Remarks

See Also

Filter Class


ButterworthPoles Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.ButterworthPoles Method
Filter Class See Also Send Feedback
Calculates pole positions for Butterworth design low-pass filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex[] ButterworthPoles(
    double freq,
    int nsection
)
Visual Basic (Declaration)
Public Shared Function ButterworthPoles ( _
    freq As Double, _
    nsection As Integer _
) As Complex()
Visual C++
public:
static array<Complex^>^ ButterworthPoles(
    double freq,
    int nsection
)

Parameters

freq
Type: System..::.Double
Normalised cut-off frequency (0-0.5)
nsection
Type: System..::.Int32
Number of second order sections

Return Value

Array of pole positions on z-plane

Remarks

See Also

Filter Class


Convolve Method

[image] [image]

BasicDSP - Digital Signal Processing Library
Filter..::.Convolve Method
Filter Class See Also Send Feedback

Overload List

Name | Description
Convolve(Waveform%, Waveform%) | Convolves two waveforms
Convolve(Waveform%, array<Double>[]()[]%) | Convolves a waveforms with a double array

See Also

Filter Class
Filter Members


Convolve Method (Waveform, Waveform)

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.Convolve Method (Waveform%, Waveform%)
Filter Class See Also Send Feedback
Convolves two waveforms

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Waveform Convolve(
    ref Waveform x,
    ref Waveform h
)
Visual Basic (Declaration)
Public Shared Function Convolve ( _
    ByRef x As Waveform, _
    ByRef h As Waveform _
) As Waveform
Visual C++
public:
static Waveform^ Convolve(
    Waveform^% x,
    Waveform^% h
)

Parameters

x
Type: BasicDSP..::.Waveform %
Input waveform
h
Type: BasicDSP..::.Waveform %
Input impulse response

Return Value

Convolution of inputs

Remarks

See Also

Filter Class
Convolve Overload


Convolve Method (Waveform, Double[])

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.Convolve Method (Waveform%, array<Double>[]()[]%)
Filter Class See Also Send Feedback
Convolves a waveforms with a double array

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Waveform Convolve(
    ref Waveform x,
    ref double[] h
)
Visual Basic (Declaration)
Public Shared Function Convolve ( _
    ByRef x As Waveform, _
    ByRef h As Double() _
) As Waveform
Visual C++
public:
static Waveform^ Convolve(
    Waveform^% x,
    array<double>^% h
)

Parameters

x
Type: BasicDSP..::.Waveform %
Input waveform
h
Type: array< System..::.Double >[]()[] %
Input impulse response

Return Value

Convolution of inputs

Remarks

See Also

Filter Class
Convolve Overload


NRBandPass Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.NRBandPass Method
Filter Class See Also Send Feedback
Design non-recursive band-pass filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem NRBandPass(
    double lofreq,
    double hifreq,
    int ncoeff
)
Visual Basic (Declaration)
Public Shared Function NRBandPass ( _
    lofreq As Double, _
    hifreq As Double, _
    ncoeff As Integer _
) As LTISystem
Visual C++
public:
static LTISystem^ NRBandPass(
    double lofreq,
    double hifreq,
    int ncoeff
)

Parameters

lofreq
Type: System..::.Double
Normalised lower cut-off frequency
hifreq
Type: System..::.Double
Normalised upper cut-off frequency
ncoeff
Type: System..::.Int32
Length of desired impulse response

Return Value

Linear system containing filter

Remarks

See Also

Filter Class


NRBandPassTransform Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.NRBandPassTransform Method
Filter Class See Also Send Feedback
Transform non-recursive low-pass filter to band-pass

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem NRBandPassTransform(
    LTISystem lpfilt,
    double freq
)
Visual Basic (Declaration)
Public Shared Function NRBandPassTransform ( _
    lpfilt As LTISystem, _
    freq As Double _
) As LTISystem
Visual C++
public:
static LTISystem^ NRBandPassTransform(
    LTISystem^ lpfilt,
    double freq
)

Parameters

lpfilt
Type: BasicDSP..::.LTISystem
Low-pass filter with cf = bw/2
freq
Type: System..::.Double
New centre frequency

Return Value

Band-pass filter as linear system

Remarks

See Also

Filter Class


NRHighPass Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.NRHighPass Method
Filter Class See Also Send Feedback
Design non-recursive high-pass filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem NRHighPass(
    double freq,
    int ncoeff
)
Visual Basic (Declaration)
Public Shared Function NRHighPass ( _
    freq As Double, _
    ncoeff As Integer _
) As LTISystem
Visual C++
public:
static LTISystem^ NRHighPass(
    double freq,
    int ncoeff
)

Parameters

freq
Type: System..::.Double
Normalised cut-off frequency
ncoeff
Type: System..::.Int32
Length of desired impulse response

Return Value

Linear system containing filter

Remarks

See Also

Filter Class


NRHighPassTransform Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.NRHighPassTransform Method
Filter Class See Also Send Feedback
Transform non-recursive low-pass filter to high-pass

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem NRHighPassTransform(
    LTISystem lpfilt
)
Visual Basic (Declaration)
Public Shared Function NRHighPassTransform ( _
    lpfilt As LTISystem _
) As LTISystem
Visual C++
public:
static LTISystem^ NRHighPassTransform(
    LTISystem^ lpfilt
)

Parameters

lpfilt
Type: BasicDSP..::.LTISystem
Non-recursive low-pass filter with cutoff = 0.5-cf

Return Value

High-pass filter as linear system

Remarks

See Also

Filter Class


NRLowPass Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.NRLowPass Method
Filter Class See Also Send Feedback
Design non-recursive low-pass filter.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem NRLowPass(
    double freq,
    int ncoeff
)
Visual Basic (Declaration)
Public Shared Function NRLowPass ( _
    freq As Double, _
    ncoeff As Integer _
) As LTISystem
Visual C++
public:
static LTISystem^ NRLowPass(
    double freq,
    int ncoeff
)

Parameters

freq
Type: System..::.Double
Normalised cut-off frequency, (0-0.5)
ncoeff
Type: System..::.Int32
Length of filter impulse response

Return Value

Low-pass filter as linear system

Remarks

See Also

Filter Class


Resonator Method

[image]

BasicDSP - Digital Signal Processing Library
Filter..::.Resonator Method
Filter Class See Also Send Feedback
Builds a linear system for a resonator

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem Resonator(
    double freq,
    double bwidth
)
Visual Basic (Declaration)
Public Shared Function Resonator ( _
    freq As Double, _
    bwidth As Double _
) As LTISystem
Visual C++
public:
static LTISystem^ Resonator(
    double freq,
    double bwidth
)

Parameters

freq
Type: System..::.Double
Normalised centre frequency of resonator (0-0.5)
bwidth
Type: System..::.Double
Normalised bandwidth of resonator (0-0.5)

Return Value

Resonator system

Remarks

See Also

Filter Class


Graph Class

[image]

BasicDSP - Digital Signal Processing Library
Graph Class
Members See Also Send Feedback
Supports simple graphs using the ZedGraph charting library

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Graph
Visual Basic (Declaration)
Public Class Graph
Visual C++
public ref class Graph

Remarks

ZedGraph can be downloaded from zedgraph.org

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Graph

See Also

Graph Members


Graph Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Graph Members
Graph Class Constructors Methods See Also Send Feedback

The Graph type exposes the following members.

Constructors

Name | Description
Graph | Overloaded.

Methods

Name | Description
PlotClear | Clears the lines in one sub graph
PlotCoeff | Plot a graph from an array of double values
PlotComplexWaveform | Plot a waveform from a ComplexWaveform type
PlotDbSpectrum | Plot a magnitude spectrum in decibels from a Spectrum type
PlotPhaseSpectrum | Plot a phase spectrum in degrees from a Spectrum type
PlotResize | Resize the number of graphs and change the plot title
PlotSignal | Plot a waveform from a Signal type
PlotSpectrumArg | Plot the phase in radians of a Spectrum
PlotSpectrumImag | Plot the imaginary part of a Spectrum
PlotSpectrumMag | Plot the magnitude of a Spectrum
PlotSpectrumReal | Plot the real part of a Spectrum
PlotWaveComplexArg | Plot a waveform from the argument of a WaveComplex type
PlotWaveComplexImag | Plot a waveform from the imaginary part of a WaveComplex type
PlotWaveComplexMag | Plot a waveform from the magnitude of a WaveComplex type
PlotWaveComplexReal | Plot a waveform from the real part of a WaveComplex type
PlotWaveDouble | Plot a waveform from a WaveDouble type
PlotWaveDoubleBar | Plot a bar chart from a WaveDouble type
PlotWaveform | Plot a waveform from a Waveform type
PlotWaveShort | Plot a waveform from a WaveShort type
PlotZPlane | Plot a z-plane diagram showing positions of poles and zeros

See Also

Graph Class


Graph Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
Graph Constructor
Graph Class See Also Send Feedback

Overload List

Name | Description
Graph(Graphics, ZedGraphControl) | Create new graph.
Graph(Graphics, ZedGraphControl, String) | Create new graph.
Graph(Graphics, ZedGraphControl, Int32, Int32) | Create new set of graphs.
Graph(Graphics, ZedGraphControl, Int32, Int32, String) | Create new set of graphs.

See Also

Graph Class
Graph Members


Graph Constructor (Graphics, )

[image]

BasicDSP - Digital Signal Processing Library
Graph Constructor (Graphics, )
Graph Class See Also Send Feedback
Create new graph.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Graph(
    Graphics g,
    ZedGraphControl zgc
)
Visual Basic (Declaration)
Public Sub New ( _
    g As Graphics, _
    zgc As ZedGraphControl _
)
Visual C++
public:
Graph(
    Graphics^ g,
    ZedGraphControl^ zgc
)

Parameters

g
Type: System.Drawing..::.Graphics
Graphics object to draw on
zgc
Type: ZedGraphControl
ZedGraph control

Remarks

See Also

Graph Class
Graph Overload


Graph Constructor (Graphics, , String)

[image]

BasicDSP - Digital Signal Processing Library
Graph Constructor (Graphics, , String)
Graph Class See Also Send Feedback
Create new graph.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Graph(
    Graphics g,
    ZedGraphControl zgc,
    string maintitle
)
Visual Basic (Declaration)
Public Sub New ( _
    g As Graphics, _
    zgc As ZedGraphControl, _
    maintitle As String _
)
Visual C++
public:
Graph(
    Graphics^ g,
    ZedGraphControl^ zgc,
    String^ maintitle
)

Parameters

g
Type: System.Drawing..::.Graphics
Graphics object to draw on
zgc
Type: ZedGraphControl
ZedGraph control
maintitle
Type: System..::.String
Graph main title

Remarks

See Also

Graph Class
Graph Overload


Graph Constructor (Graphics, , Int32, Int32)

[image]

BasicDSP - Digital Signal Processing Library
Graph Constructor (Graphics, , Int32, Int32)
Graph Class See Also Send Feedback
Create new set of graphs.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Graph(
    Graphics g,
    ZedGraphControl zgc,
    int nrows,
    int ncols
)
Visual Basic (Declaration)
Public Sub New ( _
    g As Graphics, _
    zgc As ZedGraphControl, _
    nrows As Integer, _
    ncols As Integer _
)
Visual C++
public:
Graph(
    Graphics^ g,
    ZedGraphControl^ zgc,
    int nrows,
    int ncols
)

Parameters

g
Type: System.Drawing..::.Graphics
Graphics object to draw on
zgc
Type: ZedGraphControl
ZedGraph control
nrows
Type: System..::.Int32
Number of vertical graphs
ncols
Type: System..::.Int32
Number of horizontal graphs

Remarks

See Also

Graph Class
Graph Overload


Graph Constructor (Graphics, , Int32, Int32, String)

[image]

BasicDSP - Digital Signal Processing Library
Graph Constructor (Graphics, , Int32, Int32, String)
Graph Class See Also Send Feedback
Create new set of graphs.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Graph(
    Graphics g,
    ZedGraphControl zgc,
    int nrows,
    int ncols,
    string maintitle
)
Visual Basic (Declaration)
Public Sub New ( _
    g As Graphics, _
    zgc As ZedGraphControl, _
    nrows As Integer, _
    ncols As Integer, _
    maintitle As String _
)
Visual C++
public:
Graph(
    Graphics^ g,
    ZedGraphControl^ zgc,
    int nrows,
    int ncols,
    String^ maintitle
)

Parameters

g
Type: System.Drawing..::.Graphics
Graphics object to draw on
zgc
Type: ZedGraphControl
ZedGraph control
nrows
Type: System..::.Int32
Number of vertical graphs
ncols
Type: System..::.Int32
Number of horizontal graphs
maintitle
Type: System..::.String
Graph main title

Remarks

See Also

Graph Class
Graph Overload


Graph Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Graph Methods
Graph Class See Also Send Feedback

The Graph type exposes the following members.

Methods

Name | Description
PlotClear | Clears the lines in one sub graph
PlotCoeff | Plot a graph from an array of double values
PlotComplexWaveform | Plot a waveform from a ComplexWaveform type
PlotDbSpectrum | Plot a magnitude spectrum in decibels from a Spectrum type
PlotPhaseSpectrum | Plot a phase spectrum in degrees from a Spectrum type
PlotResize | Resize the number of graphs and change the plot title
PlotSignal | Plot a waveform from a Signal type
PlotSpectrumArg | Plot the phase in radians of a Spectrum
PlotSpectrumImag | Plot the imaginary part of a Spectrum
PlotSpectrumMag | Plot the magnitude of a Spectrum
PlotSpectrumReal | Plot the real part of a Spectrum
PlotWaveComplexArg | Plot a waveform from the argument of a WaveComplex type
PlotWaveComplexImag | Plot a waveform from the imaginary part of a WaveComplex type
PlotWaveComplexMag | Plot a waveform from the magnitude of a WaveComplex type
PlotWaveComplexReal | Plot a waveform from the real part of a WaveComplex type
PlotWaveDouble | Plot a waveform from a WaveDouble type
PlotWaveDoubleBar | Plot a bar chart from a WaveDouble type
PlotWaveform | Plot a waveform from a Waveform type
PlotWaveShort | Plot a waveform from a WaveShort type
PlotZPlane | Plot a z-plane diagram showing positions of poles and zeros

See Also

Graph Class


PlotClear Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotClear Method
Graph Class See Also Send Feedback
Clears the lines in one sub graph

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotClear(
    int gno
)
Visual Basic (Declaration)
Public Sub PlotClear ( _
    gno As Integer _
)
Visual C++
public:
void PlotClear(
    int gno
)

Parameters

gno
Type: System..::.Int32
Graph number

Remarks

See Also

Graph Class


PlotCoeff Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotCoeff Method
Graph Class See Also Send Feedback
Plot a graph from an array of double values

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotCoeff(
    int gno,
    ref double[] wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Sub PlotCoeff ( _
    gno As Integer, _
    ByRef wv As Double(), _
    title As String, _
    ylabel As String, _
    xlabel As String _
)
Visual C++
public:
void PlotCoeff(
    int gno,
    array<double>^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: array< System..::.Double >[]()[] %
Double array of values
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Remarks

See Also

Graph Class


PlotComplexWaveform Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotComplexWaveform Method
Graph Class See Also Send Feedback
Plot a waveform from a ComplexWaveform type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotComplexWaveform(
    int gno,
    ref ComplexWaveform wv,
    string title
)
Visual Basic (Declaration)
Public Sub PlotComplexWaveform ( _
    gno As Integer, _
    ByRef wv As ComplexWaveform, _
    title As String _
)
Visual C++
public:
void PlotComplexWaveform(
    int gno,
    ComplexWaveform^% wv,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.ComplexWaveform %
Signal
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotDbSpectrum Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotDbSpectrum Method
Graph Class See Also Send Feedback
Plot a magnitude spectrum in decibels from a Spectrum type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotDbSpectrum(
    int gno,
    ref Spectrum sp,
    string title
)
Visual Basic (Declaration)
Public Sub PlotDbSpectrum ( _
    gno As Integer, _
    ByRef sp As Spectrum, _
    title As String _
)
Visual C++
public:
void PlotDbSpectrum(
    int gno,
    Spectrum^% sp,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
sp
Type: BasicDSP..::.Spectrum %
Spectrum
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotPhaseSpectrum Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotPhaseSpectrum Method
Graph Class See Also Send Feedback
Plot a phase spectrum in degrees from a Spectrum type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotPhaseSpectrum(
    int gno,
    ref Spectrum sp,
    string title
)
Visual Basic (Declaration)
Public Sub PlotPhaseSpectrum ( _
    gno As Integer, _
    ByRef sp As Spectrum, _
    title As String _
)
Visual C++
public:
void PlotPhaseSpectrum(
    int gno,
    Spectrum^% sp,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
sp
Type: BasicDSP..::.Spectrum %
Spectrum
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotResize Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotResize Method
Graph Class See Also Send Feedback
Resize the number of graphs and change the plot title

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotResize(
    int nrows,
    int ncols,
    string maintitle
)
Visual Basic (Declaration)
Public Sub PlotResize ( _
    nrows As Integer, _
    ncols As Integer, _
    maintitle As String _
)
Visual C++
public:
void PlotResize(
    int nrows,
    int ncols,
    String^ maintitle
)

Parameters

nrows
Type: System..::.Int32
Number of vertical graphs
ncols
Type: System..::.Int32
Number of horizontal graphs
maintitle
Type: System..::.String
Graph main title

Remarks

See Also

Graph Class


PlotSignal Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotSignal Method
Graph Class See Also Send Feedback
Plot a waveform from a Signal type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotSignal(
    int gno,
    ref Signal wv,
    string title
)
Visual Basic (Declaration)
Public Sub PlotSignal ( _
    gno As Integer, _
    ByRef wv As Signal, _
    title As String _
)
Visual C++
public:
void PlotSignal(
    int gno,
    Signal^% wv,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.Signal %
Signal
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotSpectrumArg Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotSpectrumArg Method
Graph Class See Also Send Feedback
Plot the phase in radians of a Spectrum

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotSpectrumArg(
    int gno,
    ref Spectrum sp,
    string title
)
Visual Basic (Declaration)
Public Sub PlotSpectrumArg ( _
    gno As Integer, _
    ByRef sp As Spectrum, _
    title As String _
)
Visual C++
public:
void PlotSpectrumArg(
    int gno,
    Spectrum^% sp,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
sp
Type: BasicDSP..::.Spectrum %
Spectrum
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotSpectrumImag Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotSpectrumImag Method
Graph Class See Also Send Feedback
Plot the imaginary part of a Spectrum

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotSpectrumImag(
    int gno,
    ref Spectrum sp,
    string title
)
Visual Basic (Declaration)
Public Sub PlotSpectrumImag ( _
    gno As Integer, _
    ByRef sp As Spectrum, _
    title As String _
)
Visual C++
public:
void PlotSpectrumImag(
    int gno,
    Spectrum^% sp,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
sp
Type: BasicDSP..::.Spectrum %
Spectrum
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotSpectrumMag Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotSpectrumMag Method
Graph Class See Also Send Feedback
Plot the magnitude of a Spectrum

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotSpectrumMag(
    int gno,
    ref Spectrum sp,
    string title
)
Visual Basic (Declaration)
Public Sub PlotSpectrumMag ( _
    gno As Integer, _
    ByRef sp As Spectrum, _
    title As String _
)
Visual C++
public:
void PlotSpectrumMag(
    int gno,
    Spectrum^% sp,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
sp
Type: BasicDSP..::.Spectrum %
Spectrum
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotSpectrumReal Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotSpectrumReal Method
Graph Class See Also Send Feedback
Plot the real part of a Spectrum

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotSpectrumReal(
    int gno,
    ref Spectrum sp,
    string title
)
Visual Basic (Declaration)
Public Sub PlotSpectrumReal ( _
    gno As Integer, _
    ByRef sp As Spectrum, _
    title As String _
)
Visual C++
public:
void PlotSpectrumReal(
    int gno,
    Spectrum^% sp,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
sp
Type: BasicDSP..::.Spectrum %
Spectrum
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotWaveComplexArg Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveComplexArg Method
Graph Class See Also Send Feedback
Plot a waveform from the argument of a WaveComplex type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotWaveComplexArg(
    int gno,
    ref WaveComplex wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Sub PlotWaveComplexArg ( _
    gno As Integer, _
    ByRef wv As WaveComplex, _
    title As String, _
    ylabel As String, _
    xlabel As String _
)
Visual C++
public:
void PlotWaveComplexArg(
    int gno,
    WaveComplex^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.WaveComplex %
Input waveform
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Remarks

See Also

Graph Class


PlotWaveComplexImag Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveComplexImag Method
Graph Class See Also Send Feedback
Plot a waveform from the imaginary part of a WaveComplex type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotWaveComplexImag(
    int gno,
    ref WaveComplex wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Sub PlotWaveComplexImag ( _
    gno As Integer, _
    ByRef wv As WaveComplex, _
    title As String, _
    ylabel As String, _
    xlabel As String _
)
Visual C++
public:
void PlotWaveComplexImag(
    int gno,
    WaveComplex^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.WaveComplex %
Input waveform
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Remarks

See Also

Graph Class


PlotWaveComplexMag Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveComplexMag Method
Graph Class See Also Send Feedback
Plot a waveform from the magnitude of a WaveComplex type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotWaveComplexMag(
    int gno,
    ref WaveComplex wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Sub PlotWaveComplexMag ( _
    gno As Integer, _
    ByRef wv As WaveComplex, _
    title As String, _
    ylabel As String, _
    xlabel As String _
)
Visual C++
public:
void PlotWaveComplexMag(
    int gno,
    WaveComplex^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.WaveComplex %
Input waveform
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Remarks

See Also

Graph Class


PlotWaveComplexReal Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveComplexReal Method
Graph Class See Also Send Feedback
Plot a waveform from the real part of a WaveComplex type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotWaveComplexReal(
    int gno,
    ref WaveComplex wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Sub PlotWaveComplexReal ( _
    gno As Integer, _
    ByRef wv As WaveComplex, _
    title As String, _
    ylabel As String, _
    xlabel As String _
)
Visual C++
public:
void PlotWaveComplexReal(
    int gno,
    WaveComplex^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.WaveComplex %
Input waveform
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Remarks

See Also

Graph Class


PlotWaveDouble Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveDouble Method
Graph Class See Also Send Feedback
Plot a waveform from a WaveDouble type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public LineItem PlotWaveDouble(
    int gno,
    ref WaveDouble wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Function PlotWaveDouble ( _
    gno As Integer, _
    ByRef wv As WaveDouble, _
    title As String, _
    ylabel As String, _
    xlabel As String _
) As LineItem
Visual C++
public:
LineItem^ PlotWaveDouble(
    int gno,
    WaveDouble^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.WaveDouble %
Input waveform
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Return Value

Plotted curve object

Remarks

See Also

Graph Class


PlotWaveDoubleBar Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveDoubleBar Method
Graph Class See Also Send Feedback
Plot a bar chart from a WaveDouble type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public BarItem PlotWaveDoubleBar(
    int gno,
    ref WaveDouble wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Function PlotWaveDoubleBar ( _
    gno As Integer, _
    ByRef wv As WaveDouble, _
    title As String, _
    ylabel As String, _
    xlabel As String _
) As BarItem
Visual C++
public:
BarItem^ PlotWaveDoubleBar(
    int gno,
    WaveDouble^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.WaveDouble %
Input waveform
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Return Value

Plotted curve object

Remarks

See Also

Graph Class


PlotWaveform Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveform Method
Graph Class See Also Send Feedback
Plot a waveform from a Waveform type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotWaveform(
    int gno,
    ref Waveform wv,
    string title
)
Visual Basic (Declaration)
Public Sub PlotWaveform ( _
    gno As Integer, _
    ByRef wv As Waveform, _
    title As String _
)
Visual C++
public:
void PlotWaveform(
    int gno,
    Waveform^% wv,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.Waveform %
Signal
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


PlotWaveShort Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotWaveShort Method
Graph Class See Also Send Feedback
Plot a waveform from a WaveShort type

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotWaveShort(
    int gno,
    ref WaveShort wv,
    string title,
    string ylabel,
    string xlabel
)
Visual Basic (Declaration)
Public Sub PlotWaveShort ( _
    gno As Integer, _
    ByRef wv As WaveShort, _
    title As String, _
    ylabel As String, _
    xlabel As String _
)
Visual C++
public:
void PlotWaveShort(
    int gno,
    WaveShort^% wv,
    String^ title,
    String^ ylabel,
    String^ xlabel
)

Parameters

gno
Type: System..::.Int32
Graph number
wv
Type: BasicDSP..::.WaveShort %
Input waveform
title
Type: System..::.String
Graph title
ylabel
Type: System..::.String
Y-axis label
xlabel
Type: System..::.String
X-axis label

Remarks

See Also

Graph Class


PlotZPlane Method

[image]

BasicDSP - Digital Signal Processing Library
Graph..::.PlotZPlane Method
Graph Class See Also Send Feedback
Plot a z-plane diagram showing positions of poles and zeros

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void PlotZPlane(
    int gno,
    ref Complex[] poles,
    Complex[] zeros,
    string title
)
Visual Basic (Declaration)
Public Sub PlotZPlane ( _
    gno As Integer, _
    ByRef poles As Complex(), _
    zeros As Complex(), _
    title As String _
)
Visual C++
public:
void PlotZPlane(
    int gno,
    array<Complex^>^% poles,
    array<Complex^>^ zeros,
    String^ title
)

Parameters

gno
Type: System..::.Int32
Graph number
poles
Type: array< BasicDSP..::.Complex >[]()[] %
Complex array of pole positions
zeros
Type: array< BasicDSP..::.Complex >[]()[]
Complex array of zero positions
title
Type: System..::.String
Graph title

Remarks

See Also

Graph Class


LPC Class

[image]

BasicDSP - Digital Signal Processing Library
LPC Class
Members See Also Send Feedback
Library functions for Linear Prediction modelling

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class LPC
Visual Basic (Declaration)
Public Class LPC
Visual C++
public ref class LPC

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.LPC

See Also

LPC Members


LPC Members

[image] [image]

BasicDSP - Digital Signal Processing Library
LPC Members
LPC Class Constructors Methods See Also Send Feedback

The LPC type exposes the following members.

Constructors

Name | Description
LPC | Initializes a new instance of the LPC class

Methods

Name | Description
Auto | Find predictor coefficients from waveform by Levinson-Durbin recursion method
OLDRoots | Solve a real polynomial of order N into N complex roots
Solve | Find predictor coefficients from waveform by matrix solution method

See Also

LPC Class


LPC Constructor

[image]

BasicDSP - Digital Signal Processing Library
LPC Constructor
LPC Class See Also Send Feedback
Initializes a new instance of the LPC class

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public LPC()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LPC()

See Also

LPC Class


LPC Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
LPC Methods
LPC Class See Also Send Feedback

The LPC type exposes the following members.

Methods

Name | Description
Auto | Find predictor coefficients from waveform by Levinson-Durbin recursion method
OLDRoots | Solve a real polynomial of order N into N complex roots
Solve | Find predictor coefficients from waveform by matrix solution method

See Also

LPC Class


Auto Method

[image]

BasicDSP - Digital Signal Processing Library
LPC..::.Auto Method
LPC Class See Also Send Feedback
Find predictor coefficients from waveform by Levinson-Durbin recursion method

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem Auto(
    Waveform x,
    int order,
    ref double pe
)
Visual Basic (Declaration)
Public Shared Function Auto ( _
    x As Waveform, _
    order As Integer, _
    ByRef pe As Double _
) As LTISystem
Visual C++
public:
static LTISystem^ Auto(
    Waveform^ x,
    int order,
    double% pe
)

Parameters

x
Type: BasicDSP..::.Waveform
Input waveform
order
Type: System..::.Int32
Number of coefficients
pe
Type: System..::.Double %
Returned predictor error

Return Value

Linear system containing coefficients

Remarks

See Also

LPC Class


OLDRoots Method

[image]

BasicDSP - Digital Signal Processing Library
LPC..::.OLDRoots Method
LPC Class See Also Send Feedback
Solve a real polynomial of order N into N complex roots

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex[] OLDRoots(
    double[] ap,
    int m
)
Visual Basic (Declaration)
Public Shared Function OLDRoots ( _
    ap As Double(), _
    m As Integer _
) As Complex()
Visual C++
public:
static array<Complex^>^ OLDRoots(
    array<double>^ ap,
    int m
)

Parameters

ap
Type: array< System..::.Double >[]()[]
Real polynomial
m
Type: System..::.Int32
Order of polynomial

Return Value

Complex roots

Remarks

Polynomial is 1+ap(1)*x+ap(2)*x*x+ap(3)*x*x*x+...ap(m)*x^m

See Also

LPC Class


Solve Method

[image]

BasicDSP - Digital Signal Processing Library
LPC..::.Solve Method
LPC Class See Also Send Feedback
Find predictor coefficients from waveform by matrix solution method

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static LTISystem Solve(
    Waveform x,
    int order
)
Visual Basic (Declaration)
Public Shared Function Solve ( _
    x As Waveform, _
    order As Integer _
) As LTISystem
Visual C++
public:
static LTISystem^ Solve(
    Waveform^ x,
    int order
)

Parameters

x
Type: BasicDSP..::.Waveform
Input waveform
order
Type: System..::.Int32
Number of coefficients

Return Value

Linear system containing predictor coefficients

Remarks

See Also

LPC Class


LTISystem Class

[image]

BasicDSP - Digital Signal Processing Library
LTISystem Class
Members See Also Send Feedback
Class to support creation and application of Linear System models

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class LTISystem
Visual Basic (Declaration)
Public Class LTISystem
Visual C++
public ref class LTISystem

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.LTISystem

See Also

LTISystem Members


LTISystem Members

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystem Members
LTISystem Class Constructors Methods Fields Properties See Also Send Feedback

The LTISystem type exposes the following members.

Constructors

Name | Description
LTISystem | Overloaded.

Methods

Name | Description
Clear | Clear the state memory
Filter | Overloaded.
Response | Calculate frequency response of linear system at a single frequency

Fields

Name | Description
a | Numerator coefficients
b | Denominator coefficients
s | Internal state memory

Properties

Name | Description
Item | Pass a single sample value through the linear system

See Also

LTISystem Class


LTISystem Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystem Constructor
LTISystem Class See Also Send Feedback

Overload List

Name | Description
LTISystem(LTISystem) | Create a copy of a linear system
LTISystem(Int32, Int32) | Create new linear system

See Also

LTISystem Class
LTISystem Members


LTISystem Constructor (LTISystem)

[image]

BasicDSP - Digital Signal Processing Library
LTISystem Constructor (LTISystem)
LTISystem Class See Also Send Feedback
Create a copy of a linear system

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public LTISystem(
    LTISystem ltis
)
Visual Basic (Declaration)
Public Sub New ( _
    ltis As LTISystem _
)
Visual C++
public:
LTISystem(
    LTISystem^ ltis
)

Parameters

ltis
Type: BasicDSP..::.LTISystem
Input linear system

Remarks

See Also

LTISystem Class
LTISystem Overload


LTISystem Constructor (Int32, Int32)

[image]

BasicDSP - Digital Signal Processing Library
LTISystem Constructor (Int32, Int32)
LTISystem Class See Also Send Feedback
Create new linear system

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public LTISystem(
    int na,
    int nb
)
Visual Basic (Declaration)
Public Sub New ( _
    na As Integer, _
    nb As Integer _
)
Visual C++
public:
LTISystem(
    int na,
    int nb
)

Parameters

na
Type: System..::.Int32
Number of numerator coefficients
nb
Type: System..::.Int32
Number of denominator coefficients

Remarks

See Also

LTISystem Class
LTISystem Overload


LTISystem Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystem Fields
LTISystem Class See Also Send Feedback

The LTISystem type exposes the following members.

Fields

Name | Description
a | Numerator coefficients
b | Denominator coefficients
s | Internal state memory

See Also

LTISystem Class


a Field

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.a Field
LTISystem Class See Also Send Feedback
Numerator coefficients

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double[] a
Visual Basic (Declaration)
Public a As Double()
Visual C++
public:
array<double>^ a

Remarks

See Also

LTISystem Class


b Field

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.b Field
LTISystem Class See Also Send Feedback
Denominator coefficients

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double[] b
Visual Basic (Declaration)
Public b As Double()
Visual C++
public:
array<double>^ b

Remarks

See Also

LTISystem Class


s Field

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.s Field
LTISystem Class See Also Send Feedback
Internal state memory

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double[] s
Visual Basic (Declaration)
Public s As Double()
Visual C++
public:
array<double>^ s

Remarks

See Also

LTISystem Class


LTISystem Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystem Methods
LTISystem Class See Also Send Feedback

The LTISystem type exposes the following members.

Methods

Name | Description
Clear | Clear the state memory
Filter | Overloaded.
Response | Calculate frequency response of linear system at a single frequency

See Also

LTISystem Class


Clear Method

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.Clear Method
LTISystem Class See Also Send Feedback
Clear the state memory

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

Remarks

See Also

LTISystem Class


Filter Method

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.Filter Method
LTISystem Class See Also Send Feedback

Overload List

Name | Description
Filter(Signal%) | Pass a signal through the filter
Filter(Waveform%) | Pass a waveform through the filter

See Also

LTISystem Class
LTISystem Members


Filter Method (Signal)

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.Filter Method (Signal%)
LTISystem Class See Also Send Feedback
Pass a signal through the filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal Filter(
    ref Signal iwv
)
Visual Basic (Declaration)
Public Function Filter ( _
    ByRef iwv As Signal _
) As Signal
Visual C++
public:
Signal^ Filter(
    Signal^% iwv
)

Parameters

iwv
Type: BasicDSP..::.Signal %
Input signal

Return Value

Filtered waveform

Remarks

See Also

LTISystem Class
Filter Overload


Filter Method (Waveform)

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.Filter Method (Waveform%)
LTISystem Class See Also Send Feedback
Pass a waveform through the filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Filter(
    ref Waveform iwv
)
Visual Basic (Declaration)
Public Function Filter ( _
    ByRef iwv As Waveform _
) As Waveform
Visual C++
public:
Waveform^ Filter(
    Waveform^% iwv
)

Parameters

iwv
Type: BasicDSP..::.Waveform %
Input waveform

Return Value

Filtered waveform

Remarks

See Also

LTISystem Class
Filter Overload


Response Method

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.Response Method
LTISystem Class See Also Send Feedback
Calculate frequency response of linear system at a single frequency

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex Response(
    double freq
)
Visual Basic (Declaration)
Public Function Response ( _
    freq As Double _
) As Complex
Visual C++
public:
Complex^ Response(
    double freq
)

Parameters

freq
Type: System..::.Double
Normalised frequency (0-0.5)

Return Value

Complex response at given frequency

Remarks

See Also

LTISystem Class


LTISystem Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystem Properties
LTISystem Class See Also Send Feedback

The LTISystem type exposes the following members.

Properties

Name | Description
Item | Pass a single sample value through the linear system

See Also

LTISystem Class


Item Property

[image]

BasicDSP - Digital Signal Processing Library
LTISystem..::.Item Property
LTISystem Class See Also Send Feedback
Pass a single sample value through the linear system

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double this[
    double ival
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    ival As Double _
) As Double
Visual C++
public:
property double default[double ival] {
    double get (double ival);
}

Parameters

ival
Type: System..::.Double
Input sample value

Field Value

Processed sample

Return Value

Processed value

Remarks

See Also

LTISystem Class


LTISystemChain Class

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain Class
Members See Also Send Feedback
Supports chain of linear systems

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class LTISystemChain
Visual Basic (Declaration)
Public Class LTISystemChain
Visual C++
public ref class LTISystemChain

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.LTISystemChain

See Also

LTISystemChain Members


LTISystemChain Members

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystemChain Members
LTISystemChain Class Constructors Methods Properties See Also Send Feedback

The LTISystemChain type exposes the following members.

Constructors

Name | Description
LTISystemChain | Overloaded.

Methods

Name | Description
Clear | Clears state memory in all linear system chain
Filter | Overloaded.

Properties

Name | Description
Item | Processes a single sample value through the chain
NSection | Gets number of linear systems in chain.
Response | Gets response of linear system chain at given frequency
Section | Gets/sets the linear systems in the chain

See Also

LTISystemChain Class


LTISystemChain Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystemChain Constructor
LTISystemChain Class See Also Send Feedback

Overload List

Name | Description
LTISystemChain(LTISystemChain) | Creates copy of chain of linear systems.
LTISystemChain(Int32) | Creates chain of linear systems

See Also

LTISystemChain Class
LTISystemChain Members


LTISystemChain Constructor (LTISystemChain)

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain Constructor (LTISystemChain)
LTISystemChain Class See Also Send Feedback
Creates copy of chain of linear systems.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public LTISystemChain(
    LTISystemChain lch
)
Visual Basic (Declaration)
Public Sub New ( _
    lch As LTISystemChain _
)
Visual C++
public:
LTISystemChain(
    LTISystemChain^ lch
)

Parameters

lch
Type: BasicDSP..::.LTISystemChain
Linear system chain

Remarks

See Also

LTISystemChain Class
LTISystemChain Overload


LTISystemChain Constructor (Int32)

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain Constructor (Int32)
LTISystemChain Class See Also Send Feedback
Creates chain of linear systems

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public LTISystemChain(
    int n
)
Visual Basic (Declaration)
Public Sub New ( _
    n As Integer _
)
Visual C++
public:
LTISystemChain(
    int n
)

Parameters

n
Type: System..::.Int32
Length of chain

Remarks

See Also

LTISystemChain Class
LTISystemChain Overload


LTISystemChain Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystemChain Methods
LTISystemChain Class See Also Send Feedback

The LTISystemChain type exposes the following members.

Methods

Name | Description
Clear | Clears state memory in all linear system chain
Filter | Overloaded.

See Also

LTISystemChain Class


Clear Method

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.Clear Method
LTISystemChain Class See Also Send Feedback
Clears state memory in all linear system chain

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

Remarks

See Also

LTISystemChain Class


Filter Method

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.Filter Method
LTISystemChain Class See Also Send Feedback

Overload List

Name | Description
Filter(Signal%) | Pass a signal through the filter
Filter(Waveform%) | Pass a waveform through the filter

See Also

LTISystemChain Class
LTISystemChain Members


Filter Method (Signal)

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.Filter Method (Signal%)
LTISystemChain Class See Also Send Feedback
Pass a signal through the filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal Filter(
    ref Signal iwv
)
Visual Basic (Declaration)
Public Function Filter ( _
    ByRef iwv As Signal _
) As Signal
Visual C++
public:
Signal^ Filter(
    Signal^% iwv
)

Parameters

iwv
Type: BasicDSP..::.Signal %
Input signal

Return Value

Filtered waveform

Remarks

See Also

LTISystemChain Class
Filter Overload


Filter Method (Waveform)

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.Filter Method (Waveform%)
LTISystemChain Class See Also Send Feedback
Pass a waveform through the filter

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Filter(
    ref Waveform iwv
)
Visual Basic (Declaration)
Public Function Filter ( _
    ByRef iwv As Waveform _
) As Waveform
Visual C++
public:
Waveform^ Filter(
    Waveform^% iwv
)

Parameters

iwv
Type: BasicDSP..::.Waveform %
Input waveform

Return Value

Filtered waveform

Remarks

See Also

LTISystemChain Class
Filter Overload


LTISystemChain Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
LTISystemChain Properties
LTISystemChain Class See Also Send Feedback

The LTISystemChain type exposes the following members.

Properties

Name | Description
Item | Processes a single sample value through the chain
NSection | Gets number of linear systems in chain.
Response | Gets response of linear system chain at given frequency
Section | Gets/sets the linear systems in the chain

See Also

LTISystemChain Class


Item Property

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.Item Property
LTISystemChain Class See Also Send Feedback
Processes a single sample value through the chain

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double this[
    double ival
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    ival As Double _
) As Double
Visual C++
public:
property double default[double ival] {
    double get (double ival);
}

Parameters

ival
Type: System..::.Double
Input sample value

Field Value

Processed sample

Return Value

Procssed sample

Remarks

See Also

LTISystemChain Class


NSection Property

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.NSection Property
LTISystemChain Class See Also Send Feedback
Gets number of linear systems in chain.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public int NSection { get; }
Visual Basic (Declaration)
Public ReadOnly Property NSection As Integer
Visual C++
public:
property int NSection {
    int get ();
}

Field Value

Number of linear systems in chain

Return Value

Number of linear systems in chain

Remarks

See Also

LTISystemChain Class


Response Property

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.Response Property
LTISystemChain Class See Also Send Feedback
Gets response of linear system chain at given frequency

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex Response[
    double freq
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Response ( _
    freq As Double _
) As Complex
Visual C++
public:
property Complex^ Response[double freq] {
    Complex^ get (double freq);
}

Parameters

freq
Type: System..::.Double
Normalised frequency (0-0.5)

Field Value

Response at given frequency

Return Value

Complex response at given frequency

Remarks

See Also

LTISystemChain Class


Section Property

[image]

BasicDSP - Digital Signal Processing Library
LTISystemChain..::.Section Property
LTISystemChain Class See Also Send Feedback
Gets/sets the linear systems in the chain

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public LTISystem Section[
    int idx
] { get; set; }
Visual Basic (Declaration)
Public Property Section ( _
    idx As Integer _
) As LTISystem
Visual C++
public:
property LTISystem^ Section[int idx] {
    LTISystem^ get (int idx);
    void set (int idx, LTISystem^ value);
}

Parameters

idx
Type: System..::.Int32
Linear system index

Field Value

Linear system

Return Value

Linear system at index

Remarks

See Also

LTISystemChain Class


Roots Class

[image]

BasicDSP - Digital Signal Processing Library
Roots Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:BasicDSP.Roots"]

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Roots
Visual Basic (Declaration)
Public Class Roots
Visual C++
public ref class Roots

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Roots

See Also

Roots Members


Roots Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Roots Members
Roots Class Constructors Methods See Also Send Feedback

The Roots type exposes the following members.

Constructors

Name | Description
Roots | Initializes a new instance of the Roots class

Methods

Name | Description
FindRoots | Solve a real polynomial of order N into N complex roots

See Also

Roots Class


Roots Constructor

[image]

BasicDSP - Digital Signal Processing Library
Roots Constructor
Roots Class See Also Send Feedback
Initializes a new instance of the Roots class

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Roots()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Roots()

See Also

Roots Class


Roots Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Roots Methods
Roots Class See Also Send Feedback

The Roots type exposes the following members.

Methods

Name | Description
FindRoots | Solve a real polynomial of order N into N complex roots

See Also

Roots Class


FindRoots Method

[image]

BasicDSP - Digital Signal Processing Library
Roots..::.FindRoots Method
Roots Class See Also Send Feedback
Solve a real polynomial of order N into N complex roots

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Complex[] FindRoots(
    double[] ap,
    int m
)
Visual Basic (Declaration)
Public Shared Function FindRoots ( _
    ap As Double(), _
    m As Integer _
) As Complex()
Visual C++
public:
static array<Complex^>^ FindRoots(
    array<double>^ ap,
    int m
)

Parameters

ap
Type: array< System..::.Double >[]()[]
Real polynomial
m
Type: System..::.Int32
Order of polynomial

Return Value

Complex roots

Remarks

Polynomial is 1+ap(1)*x+ap(2)*x*x+ap(3)*x*x*x+...+ap(m)*x^m

See Also

Roots Class


Sample Class

[image]

BasicDSP - Digital Signal Processing Library
Sample Class
Members See Also Send Feedback
Library functions to sample from various signal sources

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Sample
Visual Basic (Declaration)
Public Class Sample
Visual C++
public ref class Sample

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Sample

See Also

Sample Members


Sample Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Sample Members
Sample Class Constructors Methods See Also Send Feedback

The Sample type exposes the following members.

Constructors

Name | Description
Sample | Initializes a new instance of the Sample class

Methods

Name | Description
Noise | Sample from a normal random distribution
Quantise | Quantise a sample
Sine | Sine - compute a sample from a sinewave

See Also

Sample Class


Sample Constructor

[image]

BasicDSP - Digital Signal Processing Library
Sample Constructor
Sample Class See Also Send Feedback
Initializes a new instance of the Sample class

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Sample()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sample()

See Also

Sample Class


Sample Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Sample Methods
Sample Class See Also Send Feedback

The Sample type exposes the following members.

Methods

Name | Description
Noise | Sample from a normal random distribution
Quantise | Quantise a sample
Sine | Sine - compute a sample from a sinewave

See Also

Sample Class


Noise Method

[image]

BasicDSP - Digital Signal Processing Library
Sample..::.Noise Method
Sample Class See Also Send Feedback
Sample from a normal random distribution

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Object Noise(
    double amp
)
Visual Basic (Declaration)
Public Shared Function Noise ( _
    amp As Double _
) As Object
Visual C++
public:
static Object^ Noise(
    double amp
)

Parameters

amp
Type: System..::.Double
Amplitude scale

Return Value

Random normal sample

Remarks

See Also

Sample Class


Quantise Method

[image]

BasicDSP - Digital Signal Processing Library
Sample..::.Quantise Method
Sample Class See Also Send Feedback
Quantise a sample

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static short Quantise(
    double amp,
    double quanta
)
Visual Basic (Declaration)
Public Shared Function Quantise ( _
    amp As Double, _
    quanta As Double _
) As Short
Visual C++
public:
static short Quantise(
    double amp,
    double quanta
)

Parameters

amp
Type: System..::.Double
Input amplitude
quanta
Type: System..::.Double
Size of quantisation level

Return Value

Quantised sample

Remarks

See Also

Sample Class


Sine Method

[image]

BasicDSP - Digital Signal Processing Library
Sample..::.Sine Method
Sample Class See Also Send Feedback
Sine - compute a sample from a sinewave

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Object Sine(
    double freq,
    double amp,
    double phase,
    double time
)
Visual Basic (Declaration)
Public Shared Function Sine ( _
    freq As Double, _
    amp As Double, _
    phase As Double, _
    time As Double _
) As Object
Visual C++
public:
static Object^ Sine(
    double freq,
    double amp,
    double phase,
    double time
)

Parameters

freq
Type: System..::.Double
Frequency of sinewave (Hz)
amp
Type: System..::.Double
Amplitude of sinewave
phase
Type: System..::.Double
Initial phase of sinewave (degrees)
time
Type: System..::.Double
Time of sample

Return Value

Sinewave sample

Remarks

See Also

Sample Class


Signal Class

[image]

BasicDSP - Digital Signal Processing Library
Signal Class
Members See Also Send Feedback
Support for sampled waveforms quantised into short integers

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Signal : WaveShort
Visual Basic (Declaration)
Public Class Signal _
    Inherits WaveShort
Visual C++
public ref class Signal : public WaveShort

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveShort
BasicDSP..::.Signal

See Also

Signal Members


Signal Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Signal Members
Signal Class Constructors Methods Fields Properties See Also Send Feedback

The Signal type exposes the following members.

Constructors

Name | Description
Signal | Overloaded.

Methods

Name | Description
Add | Adds a new sample to the end of the waveform (Inherited from WaveShort.)
Cut | Cuts a portion out of a signal
Float | Convert quantised signal into float waveform
LoadWaveFile | Loads a signal from a RIFF (.WAV) format audio file
RecordAbort | Aborts recording as soon as possible
RecordDone | Finalises recording and returns signal
Recording | Test whether recording is in progress
RecordStart | Start audio recording
RecordWait | Waits for recording to complete
Replay | Replay signal
SaveWaveFile | Saves signal into RIFF (.WAV) format audio file

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Sample array. (Inherited from WaveShort.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Get/set sample at given index (Inherited from WaveShort.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

Signal Class


Signal Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
Signal Constructor
Signal Class See Also Send Feedback

Overload List

Name | Description
Signal()()() | Creates an empty signal
Signal(String) | Create a signal from an audio file
Signal(Int32, Double) | Create signal of given size and sampling rate

See Also

Signal Class
Signal Members


Signal Constructor

[image]

BasicDSP - Digital Signal Processing Library
Signal Constructor
Signal Class See Also Send Feedback
Creates an empty signal

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Signal()

Remarks

Actually creates a short section of silence

See Also

Signal Class
Signal Overload


Signal Constructor (String)

[image]

BasicDSP - Digital Signal Processing Library
Signal Constructor (String)
Signal Class See Also Send Feedback
Create a signal from an audio file

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal(
    string fname
)
Visual Basic (Declaration)
Public Sub New ( _
    fname As String _
)
Visual C++
public:
Signal(
    String^ fname
)

Parameters

fname
Type: System..::.String
Filename

Remarks

Only RIFF format (.WAV) files containing linear-PCM encoded waveforms are supported.

See Also

Signal Class
Signal Overload


Signal Constructor (Int32, Double)

[image]

BasicDSP - Digital Signal Processing Library
Signal Constructor (Int32, Double)
Signal Class See Also Send Feedback
Create signal of given size and sampling rate

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal(
    int length,
    double rate
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double _
)
Visual C++
public:
Signal(
    int length,
    double rate
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate

Remarks

See Also

Signal Class
Signal Overload


Signal Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
Signal Fields
Signal Class See Also Send Feedback

The Signal type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Sample array. (Inherited from WaveShort.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

See Also

Signal Class


Signal Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Signal Methods
Signal Class See Also Send Feedback

The Signal type exposes the following members.

Methods

Name | Description
Add | Adds a new sample to the end of the waveform (Inherited from WaveShort.)
Cut | Cuts a portion out of a signal
Float | Convert quantised signal into float waveform
LoadWaveFile | Loads a signal from a RIFF (.WAV) format audio file
RecordAbort | Aborts recording as soon as possible
RecordDone | Finalises recording and returns signal
Recording | Test whether recording is in progress
RecordStart | Start audio recording
RecordWait | Waits for recording to complete
Replay | Replay signal
SaveWaveFile | Saves signal into RIFF (.WAV) format audio file

See Also

Signal Class


Cut Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.Cut Method
Signal Class See Also Send Feedback
Cuts a portion out of a signal

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal Cut(
    int first,
    int len
)
Visual Basic (Declaration)
Public Function Cut ( _
    first As Integer, _
    len As Integer _
) As Signal
Visual C++
public:
Signal^ Cut(
    int first,
    int len
)

Parameters

first
Type: System..::.Int32
Index of first sample
len
Type: System..::.Int32
Number of samples

Return Value

Cut portion

Remarks

See Also

Signal Class


Float Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.Float Method
Signal Class See Also Send Feedback
Convert quantised signal into float waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Float()
Visual Basic (Declaration)
Public Function Float As Waveform
Visual C++
public:
Waveform^ Float()

Return Value

Float waveform

Remarks

See Also

Signal Class


LoadWaveFile Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.LoadWaveFile Method
Signal Class See Also Send Feedback
Loads a signal from a RIFF (.WAV) format audio file

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public bool LoadWaveFile(
    string sSoundFile
)
Visual Basic (Declaration)
Public Function LoadWaveFile ( _
    sSoundFile As String _
) As Boolean
Visual C++
public:
bool LoadWaveFile(
    String^ sSoundFile
)

Parameters

sSoundFile
Type: System..::.String
Filename

Return Value

Success flag

Remarks

Only Linear PCM-encoded waveforms are supported

See Also

Signal Class


RecordAbort Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.RecordAbort Method
Signal Class See Also Send Feedback
Aborts recording as soon as possible

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void RecordAbort()
Visual Basic (Declaration)
Public Sub RecordAbort
Visual C++
public:
void RecordAbort()

Remarks

See Also

Signal Class


RecordDone Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.RecordDone Method
Signal Class See Also Send Feedback
Finalises recording and returns signal

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void RecordDone()
Visual Basic (Declaration)
Public Sub RecordDone
Visual C++
public:
void RecordDone()

Remarks

See Also

Signal Class


Recording Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.Recording Method
Signal Class See Also Send Feedback
Test whether recording is in progress

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public bool Recording()
Visual Basic (Declaration)
Public Function Recording As Boolean
Visual C++
public:
bool Recording()

Return Value

Recording flag

Remarks

See Also

Signal Class


RecordStart Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.RecordStart Method
Signal Class See Also Send Feedback
Start audio recording

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void RecordStart(
    int maxsample
)
Visual Basic (Declaration)
Public Sub RecordStart ( _
    maxsample As Integer _
)
Visual C++
public:
void RecordStart(
    int maxsample
)

Parameters

maxsample
Type: System..::.Int32
Maximum number of samples to record

Remarks

Use RecordWait()()() to wait for all samples to be recorded. Otherwise use RecordAbort()()() to stop ahead of time. Use RecordDone()()() to finalise acquisition.

See Also

Signal Class


RecordWait Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.RecordWait Method
Signal Class See Also Send Feedback
Waits for recording to complete

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void RecordWait()
Visual Basic (Declaration)
Public Sub RecordWait
Visual C++
public:
void RecordWait()

Remarks

See Also

Signal Class


Replay Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.Replay Method
Signal Class See Also Send Feedback
Replay signal

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void Replay()
Visual Basic (Declaration)
Public Sub Replay
Visual C++
public:
void Replay()

Remarks

See Also

Signal Class


SaveWaveFile Method

[image]

BasicDSP - Digital Signal Processing Library
Signal..::.SaveWaveFile Method
Signal Class See Also Send Feedback
Saves signal into RIFF (.WAV) format audio file

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public bool SaveWaveFile(
    string sSoundFile
)
Visual Basic (Declaration)
Public Function SaveWaveFile ( _
    sSoundFile As String _
) As Boolean
Visual C++
public:
bool SaveWaveFile(
    String^ sSoundFile
)

Parameters

sSoundFile
Type: System..::.String
Filename

Return Value

Success flag

Remarks

Creates 16-bit linear PCM-encoding

See Also

Signal Class


Signal Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
Signal Properties
Signal Class See Also Send Feedback

The Signal type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Get/set sample at given index (Inherited from WaveShort.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

Signal Class


Spectrum Class

[image]

BasicDSP - Digital Signal Processing Library
Spectrum Class
Members See Also Send Feedback
Supports complex spectrum array

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Spectrum : WaveComplex
Visual Basic (Declaration)
Public Class Spectrum _
    Inherits WaveComplex
Visual C++
public ref class Spectrum : public WaveComplex

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveComplex
BasicDSP..::.Spectrum

See Also

Spectrum Members


Spectrum Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Spectrum Members
Spectrum Class Constructors Methods Fields Properties See Also Send Feedback

The Spectrum type exposes the following members.

Constructors

Name | Description
Spectrum | Creates new spectrum of given size and sampling rate

Methods

Name | Description
Add | Adds a single complex sample to the end of the waveform (Inherited from WaveComplex.)
Arg | Convert argument of complex waveform to waveform (Inherited from WaveComplex.)
Cut | Cuts a region out of a spectrum
Half | Cuts out the lower half of a spectrum (from 0 to Fs/2)
Imag | Convert imaginary part of complex waveform to waveform (Inherited from WaveComplex.)
Mag | Convert magnitude of complex waveform to waveform (Inherited from WaveComplex.)
Real | Convert real part of complex waveform to waveform (Inherited from WaveComplex.)

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of complex samples (Inherited from WaveComplex.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets samples by index (Inherited from WaveComplex.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

Spectrum Class


Spectrum Constructor

[image]

BasicDSP - Digital Signal Processing Library
Spectrum Constructor
Spectrum Class See Also Send Feedback
Creates new spectrum of given size and sampling rate

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Spectrum(
    int length,
    double rate
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double _
)
Visual C++
public:
Spectrum(
    int length,
    double rate
)

Parameters

length
Type: System..::.Int32
Number of harmonics
rate
Type: System..::.Double
Sanpling rate

Remarks

For N harmonics, frequencies range from 0 to (N-1)*rate/N.

See Also

Spectrum Class


Spectrum Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
Spectrum Fields
Spectrum Class See Also Send Feedback

The Spectrum type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of complex samples (Inherited from WaveComplex.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

See Also

Spectrum Class


Spectrum Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Spectrum Methods
Spectrum Class See Also Send Feedback

The Spectrum type exposes the following members.

Methods

Name | Description
Add | Adds a single complex sample to the end of the waveform (Inherited from WaveComplex.)
Arg | Convert argument of complex waveform to waveform (Inherited from WaveComplex.)
Cut | Cuts a region out of a spectrum
Half | Cuts out the lower half of a spectrum (from 0 to Fs/2)
Imag | Convert imaginary part of complex waveform to waveform (Inherited from WaveComplex.)
Mag | Convert magnitude of complex waveform to waveform (Inherited from WaveComplex.)
Real | Convert real part of complex waveform to waveform (Inherited from WaveComplex.)

See Also

Spectrum Class


Cut Method

[image]

BasicDSP - Digital Signal Processing Library
Spectrum..::.Cut Method
Spectrum Class See Also Send Feedback
Cuts a region out of a spectrum

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Spectrum Cut(
    int first,
    int len
)
Visual Basic (Declaration)
Public Function Cut ( _
    first As Integer, _
    len As Integer _
) As Spectrum
Visual C++
public:
Spectrum^ Cut(
    int first,
    int len
)

Parameters

first
Type: System..::.Int32
First harmonic index
len
Type: System..::.Int32
Number of harmonics

Return Value

Cut portion

Remarks

See Also

Spectrum Class


Half Method

[image]

BasicDSP - Digital Signal Processing Library
Spectrum..::.Half Method
Spectrum Class See Also Send Feedback
Cuts out the lower half of a spectrum (from 0 to Fs/2)

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Spectrum Half()
Visual Basic (Declaration)
Public Function Half As Spectrum
Visual C++
public:
Spectrum^ Half()

Return Value

Lower half of spectrum

Remarks

See Also

Spectrum Class


Spectrum Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
Spectrum Properties
Spectrum Class See Also Send Feedback

The Spectrum type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets samples by index (Inherited from WaveComplex.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

Spectrum Class


Utility Class

[image]

BasicDSP - Digital Signal Processing Library
Utility Class
Members See Also Send Feedback
Library functions to support miscellaneous utility operations

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public sealed class Utility
Visual Basic (Declaration)
Public NotInheritable Class Utility
Visual C++
public ref class Utility sealed

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Utility

See Also

Utility Members


Utility Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Utility Members
Utility Class Methods See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
sinc | Maths sinc() or sin(x)/(x) function

See Also

Utility Class


Utility Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Utility Methods
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
sinc | Maths sinc() or sin(x)/(x) function

See Also

Utility Class


sinc Method

[image]

BasicDSP - Digital Signal Processing Library
Utility..::.sinc Method
Utility Class See Also Send Feedback
Maths sinc() or sin(x)/(x) function

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static double sinc(
    double x
)
Visual Basic (Declaration)
Public Shared Function sinc ( _
    x As Double _
) As Double
Visual C++
public:
static double sinc(
    double x
)

Parameters

x
Type: System..::.Double
Value

Return Value

sinc(x)

Remarks

See Also

Utility Class


Wave Class

[image]

BasicDSP - Digital Signal Processing Library
Wave Class
Members See Also Send Feedback
Supports generic waveforms consisting of an array of samples at a given sampling rate.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Wave
Visual Basic (Declaration)
Public Class Wave
Visual C++
public ref class Wave

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveComplex
BasicDSP..::.WaveDouble
BasicDSP..::.WaveShort

See Also

Wave Members


Wave Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Wave Members
Wave Class Constructors Fields Properties See Also Send Feedback

The Wave type exposes the following members.

Constructors

Name | Description
Wave | Initializes a new instance of the Wave class

Fields

Name | Description
_alloc | Allocated memory size
_lobound | First index
_siz | Number of samples
_tau | Time per sample
WAVE_ALLOC_CHUNK | Size of additional allocation blocks

Properties

Name | Description
Allocsize | Get allocated memory size
Count | Get number of samples
First | Get index of first sample
Last | Get index of last sample
Period | Get sampling period
Rate | Get sampling rate

See Also

Wave Class


Wave Constructor

[image]

BasicDSP - Digital Signal Processing Library
Wave Constructor
Wave Class See Also Send Feedback
Initializes a new instance of the Wave class

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Wave()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Wave()

See Also

Wave Class


Wave Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
Wave Fields
Wave Class See Also Send Feedback

The Wave type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size
_lobound | First index
_siz | Number of samples
_tau | Time per sample
WAVE_ALLOC_CHUNK | Size of additional allocation blocks

See Also

Wave Class


_alloc Field

[image]

BasicDSP - Digital Signal Processing Library
Wave..::._alloc Field
Wave Class See Also Send Feedback
Allocated memory size

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
protected int _alloc
Visual Basic (Declaration)
Protected _alloc As Integer
Visual C++
protected:
int _alloc

Remarks

See Also

Wave Class


_lobound Field

[image]

BasicDSP - Digital Signal Processing Library
Wave..::._lobound Field
Wave Class See Also Send Feedback
First index

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
protected int _lobound
Visual Basic (Declaration)
Protected _lobound As Integer
Visual C++
protected:
int _lobound

Remarks

See Also

Wave Class


_siz Field

[image]

BasicDSP - Digital Signal Processing Library
Wave..::._siz Field
Wave Class See Also Send Feedback
Number of samples

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
protected int _siz
Visual Basic (Declaration)
Protected _siz As Integer
Visual C++
protected:
int _siz

Remarks

See Also

Wave Class


_tau Field

[image]

BasicDSP - Digital Signal Processing Library
Wave..::._tau Field
Wave Class See Also Send Feedback
Time per sample

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
protected double _tau
Visual Basic (Declaration)
Protected _tau As Double
Visual C++
protected:
double _tau

Remarks

See Also

Wave Class


WAVE_ALLOC_CHUNK Field

[image]

BasicDSP - Digital Signal Processing Library
Wave..::.WAVE_ALLOC_CHUNK Field
Wave Class See Also Send Feedback
Size of additional allocation blocks

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public const int WAVE_ALLOC_CHUNK
Visual Basic (Declaration)
Public Const WAVE_ALLOC_CHUNK As Integer
Visual C++
public:
literal int WAVE_ALLOC_CHUNK

Remarks

See Also

Wave Class


Wave Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
Wave Properties
Wave Class See Also Send Feedback

The Wave type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size
Count | Get number of samples
First | Get index of first sample
Last | Get index of last sample
Period | Get sampling period
Rate | Get sampling rate

See Also

Wave Class


Allocsize Property

[image]

BasicDSP - Digital Signal Processing Library
Wave..::.Allocsize Property
Wave Class See Also Send Feedback
Get allocated memory size

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public int Allocsize { get; }
Visual Basic (Declaration)
Public ReadOnly Property Allocsize As Integer
Visual C++
public:
property int Allocsize {
    int get ();
}

Field Value

Allocated memory size

Return Value

Allocated memory size

Remarks

See Also

Wave Class


Count Property

[image]

BasicDSP - Digital Signal Processing Library
Wave..::.Count Property
Wave Class See Also Send Feedback
Get number of samples

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

Field Value

Number of samples

Return Value

Number of samples

Remarks

See Also

Wave Class


First Property

[image]

BasicDSP - Digital Signal Processing Library
Wave..::.First Property
Wave Class See Also Send Feedback
Get index of first sample

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public int First { get; }
Visual Basic (Declaration)
Public ReadOnly Property First As Integer
Visual C++
public:
property int First {
    int get ();
}

Field Value

First index

Return Value

First index

Remarks

See Also

Wave Class


Last Property

[image]

BasicDSP - Digital Signal Processing Library
Wave..::.Last Property
Wave Class See Also Send Feedback
Get index of last sample

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public int Last { get; }
Visual Basic (Declaration)
Public ReadOnly Property Last As Integer
Visual C++
public:
property int Last {
    int get ();
}

Field Value

Last index

Return Value

Last index

Remarks

See Also

Wave Class


Period Property

[image]

BasicDSP - Digital Signal Processing Library
Wave..::.Period Property
Wave Class See Also Send Feedback
Get sampling period

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double Period { get; }
Visual Basic (Declaration)
Public ReadOnly Property Period As Double
Visual C++
public:
property double Period {
    double get ();
}

Field Value

Sampling period

Return Value

Sampling period

Remarks

See Also

Wave Class


Rate Property

[image]

BasicDSP - Digital Signal Processing Library
Wave..::.Rate Property
Wave Class See Also Send Feedback
Get sampling rate

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double Rate { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rate As Double
Visual C++
public:
property double Rate {
    double get ();
}

Field Value

Sampling rate

Return Value

Sampling rate

Remarks

See Also

Wave Class


WaveComplex Class

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex Class
Members See Also Send Feedback
Supports sampled waveforms with complex values

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class WaveComplex : Wave
Visual Basic (Declaration)
Public Class WaveComplex _
    Inherits Wave
Visual C++
public ref class WaveComplex : public Wave

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveComplex
BasicDSP..::.ComplexWaveform
BasicDSP..::.Spectrum

See Also

WaveComplex Members


WaveComplex Members

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveComplex Members
WaveComplex Class Constructors Methods Fields Properties See Also Send Feedback

The WaveComplex type exposes the following members.

Constructors

Name | Description
WaveComplex | Overloaded.

Methods

Name | Description
Add | Adds a single complex sample to the end of the waveform
Arg | Convert argument of complex waveform to waveform
Cut | Cuts out a portion of the waveform
Imag | Convert imaginary part of complex waveform to waveform
Mag | Convert magnitude of complex waveform to waveform
Real | Convert real part of complex waveform to waveform

Operators

Name | Description
Concatenate | Concatenates two complex waveforms

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of complex samples
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets samples by index
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

WaveComplex Class


WaveComplex Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveComplex Constructor
WaveComplex Class See Also Send Feedback

Overload List

Name | Description
WaveComplex(WaveComplex) | Create copy of complex waveform
WaveComplex(Int32, Double) | Create new complex waveform
WaveComplex(Int32, Double, Int32) | Creates new complex waveform

See Also

WaveComplex Class
WaveComplex Members


WaveComplex Constructor (WaveComplex)

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex Constructor (WaveComplex)
WaveComplex Class See Also Send Feedback
Create copy of complex waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveComplex(
    WaveComplex wv
)
Visual Basic (Declaration)
Public Sub New ( _
    wv As WaveComplex _
)
Visual C++
public:
WaveComplex(
    WaveComplex^ wv
)

Parameters

wv
Type: BasicDSP..::.WaveComplex
Input complex waveform

Remarks

See Also

WaveComplex Class
WaveComplex Overload


WaveComplex Constructor (Int32, Double)

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex Constructor (Int32, Double)
WaveComplex Class See Also Send Feedback
Create new complex waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveComplex(
    int length,
    double rate
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double _
)
Visual C++
public:
WaveComplex(
    int length,
    double rate
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Samplng rate

Remarks

See Also

WaveComplex Class
WaveComplex Overload


WaveComplex Constructor (Int32, Double, Int32)

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex Constructor (Int32, Double, Int32)
WaveComplex Class See Also Send Feedback
Creates new complex waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveComplex(
    int length,
    double rate,
    int lobound
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double, _
    lobound As Integer _
)
Visual C++
public:
WaveComplex(
    int length,
    double rate,
    int lobound
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate
lobound
Type: System..::.Int32
First index

Remarks

See Also

WaveComplex Class
WaveComplex Overload


WaveComplex Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveComplex Fields
WaveComplex Class See Also Send Feedback

The WaveComplex type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of complex samples
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

See Also

WaveComplex Class


_buf Field

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::._buf Field
WaveComplex Class See Also Send Feedback
Array of complex samples

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex[] _buf
Visual Basic (Declaration)
Public _buf As Complex()
Visual C++
public:
array<Complex^>^ _buf

Remarks

See Also

WaveComplex Class


WaveComplex Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveComplex Methods
WaveComplex Class See Also Send Feedback

The WaveComplex type exposes the following members.

Methods

Name | Description
Add | Adds a single complex sample to the end of the waveform
Arg | Convert argument of complex waveform to waveform
Cut | Cuts out a portion of the waveform
Imag | Convert imaginary part of complex waveform to waveform
Mag | Convert magnitude of complex waveform to waveform
Real | Convert real part of complex waveform to waveform

Operators

Name | Description
Concatenate | Concatenates two complex waveforms

See Also

WaveComplex Class


Add Method

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Add Method
WaveComplex Class See Also Send Feedback
Adds a single complex sample to the end of the waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void Add(
    Complex value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As Complex _
)
Visual C++
public:
void Add(
    Complex^ value
)

Parameters

value
Type: BasicDSP..::.Complex
Sample value

Remarks

See Also

WaveComplex Class


Arg Method

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Arg Method
WaveComplex Class See Also Send Feedback
Convert argument of complex waveform to waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Arg()
Visual Basic (Declaration)
Public Function Arg As Waveform
Visual C++
public:
Waveform^ Arg()

Return Value

Real part of complex waveform

Remarks

See Also

WaveComplex Class


Concatenate Operator

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Concatenate Operator
WaveComplex Class See Also Send Feedback
Concatenates two complex waveforms

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
C# does not support this operator.
Visual Basic (Declaration)
Public Shared Operator & ( _
    wv1 As WaveComplex, _
    wv2 As WaveComplex _
) As WaveComplex
Visual C++
Visual C++ does not support this operator.

Parameters

wv1
Type: BasicDSP..::.WaveComplex
Input waveform
wv2
Type: BasicDSP..::.WaveComplex
Input waveform

Return Value

Concatenated waveforms

Remarks

Waveforms should match in sampling rate.

See Also

WaveComplex Class


Cut Method

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Cut Method
WaveComplex Class See Also Send Feedback
Cuts out a portion of the waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveComplex Cut(
    int first,
    int len
)
Visual Basic (Declaration)
Public Function Cut ( _
    first As Integer, _
    len As Integer _
) As WaveComplex
Visual C++
public:
WaveComplex^ Cut(
    int first,
    int len
)

Parameters

first
Type: System..::.Int32
First index
len
Type: System..::.Int32
Number of samples

Return Value

Cut portion

Remarks

See Also

WaveComplex Class


Imag Method

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Imag Method
WaveComplex Class See Also Send Feedback
Convert imaginary part of complex waveform to waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Imag()
Visual Basic (Declaration)
Public Function Imag As Waveform
Visual C++
public:
Waveform^ Imag()

Return Value

Real part of complex waveform

Remarks

See Also

WaveComplex Class


Mag Method

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Mag Method
WaveComplex Class See Also Send Feedback
Convert magnitude of complex waveform to waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Mag()
Visual Basic (Declaration)
Public Function Mag As Waveform
Visual C++
public:
Waveform^ Mag()

Return Value

Real part of complex waveform

Remarks

See Also

WaveComplex Class


Real Method

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Real Method
WaveComplex Class See Also Send Feedback
Convert real part of complex waveform to waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Real()
Visual Basic (Declaration)
Public Function Real As Waveform
Visual C++
public:
Waveform^ Real()

Return Value

Real part of complex waveform

Remarks

See Also

WaveComplex Class


WaveComplex Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveComplex Properties
WaveComplex Class See Also Send Feedback

The WaveComplex type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets samples by index
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

WaveComplex Class


Item Property

[image]

BasicDSP - Digital Signal Processing Library
WaveComplex..::.Item Property
WaveComplex Class See Also Send Feedback
Gets/sets samples by index

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Complex this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Complex
Visual C++
public:
property Complex^ default[int index] {
    Complex^ get (int index);
    void set (int index, Complex^ value);
}

Parameters

index
Type: System..::.Int32
Sample index

Field Value

Sample value

Return Value

Sample value

Remarks

See Also

WaveComplex Class


WaveDouble Class

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble Class
Members See Also Send Feedback
Supports waveforms of double precision values

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class WaveDouble : Wave
Visual Basic (Declaration)
Public Class WaveDouble _
    Inherits Wave
Visual C++
public ref class WaveDouble : public Wave

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveDouble
BasicDSP..::.Waveform

See Also

WaveDouble Members


WaveDouble Members

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveDouble Members
WaveDouble Class Constructors Methods Fields Properties See Also Send Feedback

The WaveDouble type exposes the following members.

Constructors

Name | Description
WaveDouble | Overloaded.

Methods

Name | Description
Add | Adds a sample to the end of the waveform
Cut | Cuts out a portion of a waveform

Operators

Name | Description
Concatenate | Concatenates two waveforms

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of double precision samples
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets sample at particular index
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

WaveDouble Class


WaveDouble Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveDouble Constructor
WaveDouble Class See Also Send Feedback

Overload List

Name | Description
WaveDouble(WaveDouble) | Creates copy of existing double waveforms
WaveDouble(Int32, Double) | Creates double waveform of given size and sampling rate.
WaveDouble(Int32, Double, Int32) | Creates double waveform of given size and sampling rate.

See Also

WaveDouble Class
WaveDouble Members


WaveDouble Constructor (WaveDouble)

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble Constructor (WaveDouble)
WaveDouble Class See Also Send Feedback
Creates copy of existing double waveforms

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveDouble(
    WaveDouble wv
)
Visual Basic (Declaration)
Public Sub New ( _
    wv As WaveDouble _
)
Visual C++
public:
WaveDouble(
    WaveDouble^ wv
)

Parameters

wv
Type: BasicDSP..::.WaveDouble
Input waveform

Remarks

See Also

WaveDouble Class
WaveDouble Overload


WaveDouble Constructor (Int32, Double)

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble Constructor (Int32, Double)
WaveDouble Class See Also Send Feedback
Creates double waveform of given size and sampling rate.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveDouble(
    int length,
    double rate
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double _
)
Visual C++
public:
WaveDouble(
    int length,
    double rate
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate

Remarks

See Also

WaveDouble Class
WaveDouble Overload


WaveDouble Constructor (Int32, Double, Int32)

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble Constructor (Int32, Double, Int32)
WaveDouble Class See Also Send Feedback
Creates double waveform of given size and sampling rate.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveDouble(
    int length,
    double rate,
    int lobound
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double, _
    lobound As Integer _
)
Visual C++
public:
WaveDouble(
    int length,
    double rate,
    int lobound
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate
lobound
Type: System..::.Int32
First index

Remarks

See Also

WaveDouble Class
WaveDouble Overload


WaveDouble Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveDouble Fields
WaveDouble Class See Also Send Feedback

The WaveDouble type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of double precision samples
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

See Also

WaveDouble Class


_buf Field

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble..::._buf Field
WaveDouble Class See Also Send Feedback
Array of double precision samples

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
protected double[] _buf
Visual Basic (Declaration)
Protected _buf As Double()
Visual C++
protected:
array<double>^ _buf

Remarks

See Also

WaveDouble Class


WaveDouble Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveDouble Methods
WaveDouble Class See Also Send Feedback

The WaveDouble type exposes the following members.

Methods

Name | Description
Add | Adds a sample to the end of the waveform
Cut | Cuts out a portion of a waveform

Operators

Name | Description
Concatenate | Concatenates two waveforms

See Also

WaveDouble Class


Add Method

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble..::.Add Method
WaveDouble Class See Also Send Feedback
Adds a sample to the end of the waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void Add(
    double value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As Double _
)
Visual C++
public:
void Add(
    double value
)

Parameters

value
Type: System..::.Double
Sample value to append

Remarks

See Also

WaveDouble Class


Concatenate Operator

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble..::.Concatenate Operator
WaveDouble Class See Also Send Feedback
Concatenates two waveforms

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
C# does not support this operator.
Visual Basic (Declaration)
Public Shared Operator & ( _
    wv1 As WaveDouble, _
    wv2 As WaveDouble _
) As WaveDouble
Visual C++
Visual C++ does not support this operator.

Parameters

wv1
Type: BasicDSP..::.WaveDouble
Input waveform
wv2
Type: BasicDSP..::.WaveDouble
Input waveform

Return Value

Concatenated waveforms

Remarks

Input waveforms should match in sample rate

See Also

WaveDouble Class


Cut Method

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble..::.Cut Method
WaveDouble Class See Also Send Feedback
Cuts out a portion of a waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveDouble Cut(
    int first,
    int len
)
Visual Basic (Declaration)
Public Function Cut ( _
    first As Integer, _
    len As Integer _
) As WaveDouble
Visual C++
public:
WaveDouble^ Cut(
    int first,
    int len
)

Parameters

first
Type: System..::.Int32
Starting index
len
Type: System..::.Int32
Number of samples

Return Value

Cut portion of waveform

Remarks

See Also

WaveDouble Class


WaveDouble Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveDouble Properties
WaveDouble Class See Also Send Feedback

The WaveDouble type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets sample at particular index
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

WaveDouble Class


Item Property

[image]

BasicDSP - Digital Signal Processing Library
WaveDouble..::.Item Property
WaveDouble Class See Also Send Feedback
Gets/sets sample at particular index

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public double this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Double
Visual C++
public:
property double default[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::.Int32
Sample index

Field Value

Sample value

Return Value

Sample value

Remarks

Accesses outside array are protected

See Also

WaveDouble Class


Waveform Class

[image]

BasicDSP - Digital Signal Processing Library
Waveform Class
Members See Also Send Feedback
Supports waveforms containing floating-point samples

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Waveform : WaveDouble
Visual Basic (Declaration)
Public Class Waveform _
    Inherits WaveDouble
Visual C++
public ref class Waveform : public WaveDouble

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveDouble
BasicDSP..::.Waveform

See Also

Waveform Members


Waveform Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Waveform Members
Waveform Class Constructors Methods Fields Properties See Also Send Feedback

The Waveform type exposes the following members.

Constructors

Name | Description
Waveform | Creates new waveform of given size and sampling rate

Methods

Name | Description
Add | Adds a sample to the end of the waveform (Inherited from WaveDouble.)
Complex | Converts a floating-point waveform to complex samples
Cut | Cuts out a portion of a waveform
Quantise | Overloaded.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of double precision samples (Inherited from WaveDouble.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets sample at particular index (Inherited from WaveDouble.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

Waveform Class


Waveform Constructor

[image]

BasicDSP - Digital Signal Processing Library
Waveform Constructor
Waveform Class See Also Send Feedback
Creates new waveform of given size and sampling rate

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform(
    int length,
    double rate
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double _
)
Visual C++
public:
Waveform(
    int length,
    double rate
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate

Remarks

See Also

Waveform Class


Waveform Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
Waveform Fields
Waveform Class See Also Send Feedback

The Waveform type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Array of double precision samples (Inherited from WaveDouble.)
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

See Also

Waveform Class


Waveform Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Waveform Methods
Waveform Class See Also Send Feedback

The Waveform type exposes the following members.

Methods

Name | Description
Add | Adds a sample to the end of the waveform (Inherited from WaveDouble.)
Complex | Converts a floating-point waveform to complex samples
Cut | Cuts out a portion of a waveform
Quantise | Overloaded.

See Also

Waveform Class


Complex Method

[image]

BasicDSP - Digital Signal Processing Library
Waveform..::.Complex Method
Waveform Class See Also Send Feedback
Converts a floating-point waveform to complex samples

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public ComplexWaveform Complex()
Visual Basic (Declaration)
Public Function Complex As ComplexWaveform
Visual C++
public:
ComplexWaveform^ Complex()

Return Value

Complex waveform

Remarks

See Also

Waveform Class


Cut Method

[image]

BasicDSP - Digital Signal Processing Library
Waveform..::.Cut Method
Waveform Class See Also Send Feedback
Cuts out a portion of a waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Waveform Cut(
    int first,
    int len
)
Visual Basic (Declaration)
Public Function Cut ( _
    first As Integer, _
    len As Integer _
) As Waveform
Visual C++
public:
Waveform^ Cut(
    int first,
    int len
)

Parameters

first
Type: System..::.Int32
Starting index
len
Type: System..::.Int32
Number of samples

Return Value

Cut portion

Remarks

See Also

Waveform Class


Quantise Method

[image] [image]

BasicDSP - Digital Signal Processing Library
Waveform..::.Quantise Method
Waveform Class See Also Send Feedback

Overload List

Name | Description
Quantise()()() | Quantises a floating-point waveform to short integers with automatic scaling
Quantise(Double) | Quantises a floating-point waveform to short integers

See Also

Waveform Class
Waveform Members


Quantise Method

[image]

BasicDSP - Digital Signal Processing Library
Waveform..::.Quantise Method
Waveform Class See Also Send Feedback
Quantises a floating-point waveform to short integers with automatic scaling

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal Quantise()
Visual Basic (Declaration)
Public Function Quantise As Signal
Visual C++
public:
Signal^ Quantise()

Return Value

Quantised signal

Remarks

Signal is scaled to -24000..24000

See Also

Waveform Class
Quantise Overload


Quantise Method (Double)

[image]

BasicDSP - Digital Signal Processing Library
Waveform..::.Quantise Method (Double)
Waveform Class See Also Send Feedback
Quantises a floating-point waveform to short integers

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Signal Quantise(
    double quanta
)
Visual Basic (Declaration)
Public Function Quantise ( _
    quanta As Double _
) As Signal
Visual C++
public:
Signal^ Quantise(
    double quanta
)

Parameters

quanta
Type: System..::.Double
Size of quantisation interval

Return Value

Quantised signal

Remarks

See Also

Waveform Class
Quantise Overload


Waveform Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
Waveform Properties
Waveform Class See Also Send Feedback

The Waveform type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Gets/sets sample at particular index (Inherited from WaveDouble.)
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

Waveform Class


WaveShort Class

[image]

BasicDSP - Digital Signal Processing Library
WaveShort Class
Members See Also Send Feedback
Supports waveforms with short integer samples

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class WaveShort : Wave
Visual Basic (Declaration)
Public Class WaveShort _
    Inherits Wave
Visual C++
public ref class WaveShort : public Wave

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Wave
BasicDSP..::.WaveShort
BasicDSP..::.Signal

See Also

WaveShort Members


WaveShort Members

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveShort Members
WaveShort Class Constructors Methods Fields Properties See Also Send Feedback

The WaveShort type exposes the following members.

Constructors

Name | Description
WaveShort | Overloaded.

Methods

Name | Description
Add | Adds a new sample to the end of the waveform
Cut | Cuts a portion out of the waveform

Operators

Name | Description
Concatenate | Concatenates two waveforms

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Sample array.
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Get/set sample at given index
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

WaveShort Class


WaveShort Constructor

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveShort Constructor
WaveShort Class See Also Send Feedback

Overload List

Name | Description
WaveShort(WaveShort) | Create copy of waveform of short integers
WaveShort(Int32, Double) | Create waveform of short integers.
WaveShort(Int32, Double, Int32) | Create waveform of short integers.

See Also

WaveShort Class
WaveShort Members


WaveShort Constructor (WaveShort)

[image]

BasicDSP - Digital Signal Processing Library
WaveShort Constructor (WaveShort)
WaveShort Class See Also Send Feedback
Create copy of waveform of short integers

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveShort(
    WaveShort wv
)
Visual Basic (Declaration)
Public Sub New ( _
    wv As WaveShort _
)
Visual C++
public:
WaveShort(
    WaveShort^ wv
)

Parameters

wv
Type: BasicDSP..::.WaveShort
Input waveform

Remarks

See Also

WaveShort Class
WaveShort Overload


WaveShort Constructor (Int32, Double)

[image]

BasicDSP - Digital Signal Processing Library
WaveShort Constructor (Int32, Double)
WaveShort Class See Also Send Feedback
Create waveform of short integers.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveShort(
    int length,
    double rate
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double _
)
Visual C++
public:
WaveShort(
    int length,
    double rate
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate

Remarks

See Also

WaveShort Class
WaveShort Overload


WaveShort Constructor (Int32, Double, Int32)

[image]

BasicDSP - Digital Signal Processing Library
WaveShort Constructor (Int32, Double, Int32)
WaveShort Class See Also Send Feedback
Create waveform of short integers.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveShort(
    int length,
    double rate,
    int lobound
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    rate As Double, _
    lobound As Integer _
)
Visual C++
public:
WaveShort(
    int length,
    double rate,
    int lobound
)

Parameters

length
Type: System..::.Int32
Number of samples
rate
Type: System..::.Double
Sampling rate
lobound
Type: System..::.Int32
First index

Remarks

See Also

WaveShort Class
WaveShort Overload


WaveShort Fields

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveShort Fields
WaveShort Class See Also Send Feedback

The WaveShort type exposes the following members.

Fields

Name | Description
_alloc | Allocated memory size (Inherited from Wave.)
_buf | Sample array.
_lobound | First index (Inherited from Wave.)
_siz | Number of samples (Inherited from Wave.)
_tau | Time per sample (Inherited from Wave.)

See Also

WaveShort Class


_buf Field

[image]

BasicDSP - Digital Signal Processing Library
WaveShort..::._buf Field
WaveShort Class See Also Send Feedback
Sample array.

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
protected short[] _buf
Visual Basic (Declaration)
Protected _buf As Short()
Visual C++
protected:
array<short>^ _buf

Remarks

See Also

WaveShort Class


WaveShort Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveShort Methods
WaveShort Class See Also Send Feedback

The WaveShort type exposes the following members.

Methods

Name | Description
Add | Adds a new sample to the end of the waveform
Cut | Cuts a portion out of the waveform

Operators

Name | Description
Concatenate | Concatenates two waveforms

See Also

WaveShort Class


Add Method

[image]

BasicDSP - Digital Signal Processing Library
WaveShort..::.Add Method
WaveShort Class See Also Send Feedback
Adds a new sample to the end of the waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public void Add(
    short value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As Short _
)
Visual C++
public:
void Add(
    short value
)

Parameters

value
Type: System..::.Int16
Sample value

Remarks

See Also

WaveShort Class


Concatenate Operator

[image]

BasicDSP - Digital Signal Processing Library
WaveShort..::.Concatenate Operator
WaveShort Class See Also Send Feedback
Concatenates two waveforms

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
C# does not support this operator.
Visual Basic (Declaration)
Public Shared Operator & ( _
    wv1 As WaveShort, _
    wv2 As WaveShort _
) As WaveShort
Visual C++
Visual C++ does not support this operator.

Parameters

wv1
Type: BasicDSP..::.WaveShort
Input waveform
wv2
Type: BasicDSP..::.WaveShort
Input waveform

Return Value

Concatenated waveform

Remarks

Waveforms should match in sample rate.

See Also

WaveShort Class


Cut Method

[image]

BasicDSP - Digital Signal Processing Library
WaveShort..::.Cut Method
WaveShort Class See Also Send Feedback
Cuts a portion out of the waveform

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public WaveShort Cut(
    int first,
    int len
)
Visual Basic (Declaration)
Public Function Cut ( _
    first As Integer, _
    len As Integer _
) As WaveShort
Visual C++
public:
WaveShort^ Cut(
    int first,
    int len
)

Parameters

first
Type: System..::.Int32
First sample index
len
Type: System..::.Int32
Number of samples

Return Value

Cut portion of waveform

Remarks

See Also

WaveShort Class


WaveShort Properties

[image] [image]

BasicDSP - Digital Signal Processing Library
WaveShort Properties
WaveShort Class See Also Send Feedback

The WaveShort type exposes the following members.

Properties

Name | Description
Allocsize | Get allocated memory size (Inherited from Wave.)
Count | Get number of samples (Inherited from Wave.)
First | Get index of first sample (Inherited from Wave.)
Item | Get/set sample at given index
Last | Get index of last sample (Inherited from Wave.)
Period | Get sampling period (Inherited from Wave.)
Rate | Get sampling rate (Inherited from Wave.)

See Also

WaveShort Class


Item Property

[image]

BasicDSP - Digital Signal Processing Library
WaveShort..::.Item Property
WaveShort Class See Also Send Feedback
Get/set sample at given index

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public short this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Short
Visual C++
public:
property short default[int index] {
    short get (int index);
    void set (int index, short value);
}

Parameters

index
Type: System..::.Int32
Sample index

Field Value

Sample value

Return Value

Sample value

Remarks

Accesses outside the array are protected

See Also

WaveShort Class


Window Class

[image]

BasicDSP - Digital Signal Processing Library
Window Class
Members See Also Send Feedback
Library functions to support generation and application of signal windows

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public class Window
Visual Basic (Declaration)
Public Class Window
Visual C++
public ref class Window

Remarks

Inheritance Hierarchy

System..::.Object
BasicDSP..::.Window

See Also

Window Members


Window Members

[image] [image]

BasicDSP - Digital Signal Processing Library
Window Members
Window Class Constructors Methods See Also Send Feedback

The Window type exposes the following members.

Constructors

Name | Description
Window | Initializes a new instance of the Window class

Methods

Name | Description
Hamming | Overloaded.
Kaiser | Calculates Kaiser window to specification

See Also

Window Class


Window Constructor

[image]

BasicDSP - Digital Signal Processing Library
Window Constructor
Window Class See Also Send Feedback
Initializes a new instance of the Window class

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public Window()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Window()

See Also

Window Class


Window Methods

[image] [image]

BasicDSP - Digital Signal Processing Library
Window Methods
Window Class See Also Send Feedback

The Window type exposes the following members.

Methods

Name | Description
Hamming | Overloaded.
Kaiser | Calculates Kaiser window to specification

See Also

Window Class


Hamming Method

[image] [image]

BasicDSP - Digital Signal Processing Library
Window..::.Hamming Method
Window Class See Also Send Feedback

Overload List

Name | Description
Hamming(ComplexWaveform) | Applies a Hamming window to the given complex waveform segment
Hamming(Waveform) | Applies a Hamming window to the given waveform segment
Hamming(Int32) | Calculates a Hamming window of given size

See Also

Window Class
Window Members


Hamming Method (ComplexWaveform)

[image]

BasicDSP - Digital Signal Processing Library
Window..::.Hamming Method (ComplexWaveform)
Window Class See Also Send Feedback
Applies a Hamming window to the given complex waveform segment

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static ComplexWaveform Hamming(
    ComplexWaveform iwv
)
Visual Basic (Declaration)
Public Shared Function Hamming ( _
    iwv As ComplexWaveform _
) As ComplexWaveform
Visual C++
public:
static ComplexWaveform^ Hamming(
    ComplexWaveform^ iwv
)

Parameters

iwv
Type: BasicDSP..::.ComplexWaveform
Input complex waveform segment

Return Value

Windowed waveform

Remarks

See Also

Window Class
Hamming Overload


Hamming Method (Waveform)

[image]

BasicDSP - Digital Signal Processing Library
Window..::.Hamming Method (Waveform)
Window Class See Also Send Feedback
Applies a Hamming window to the given waveform segment

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Waveform Hamming(
    Waveform iwv
)
Visual Basic (Declaration)
Public Shared Function Hamming ( _
    iwv As Waveform _
) As Waveform
Visual C++
public:
static Waveform^ Hamming(
    Waveform^ iwv
)

Parameters

iwv
Type: BasicDSP..::.Waveform
Input waveform segment

Return Value

Windowed waveform

Remarks

See Also

Window Class
Hamming Overload


Hamming Method (Int32)

[image]

BasicDSP - Digital Signal Processing Library
Window..::.Hamming Method (Int32)
Window Class See Also Send Feedback
Calculates a Hamming window of given size

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Waveform Hamming(
    int len
)
Visual Basic (Declaration)
Public Shared Function Hamming ( _
    len As Integer _
) As Waveform
Visual C++
public:
static Waveform^ Hamming(
    int len
)

Parameters

len
Type: System..::.Int32
Number of samples required in window

Return Value

Hamming window

Remarks

See Also

Window Class
Hamming Overload


Kaiser Method

[image]

BasicDSP - Digital Signal Processing Library
Window..::.Kaiser Method
Window Class See Also Send Feedback
Calculates Kaiser window to specification

Namespace: BasicDSP
Assembly: BasicDSP (in BasicDSP.dll) Version: 1.0.3.0 (1.0.3.0)

Syntax

C#
public static Waveform Kaiser(
    double ripple,
    double twidth,
    int kmaxlen
)
Visual Basic (Declaration)
Public Shared Function Kaiser ( _
    ripple As Double, _
    twidth As Double, _
    kmaxlen As Integer _
) As Waveform
Visual C++
public:
static Waveform^ Kaiser(
    double ripple,
    double twidth,
    int kmaxlen
)

Parameters

ripple
Type: System..::.Double
Desired stop-band ripple (dB)
twidth
Type: System..::.Double
Desired transition width (fraction of sample rate)
kmaxlen
Type: System..::.Int32
Maximum window size

Return Value

Second half of Kaiser window

Remarks

Reflect window about kwin(1) to get symmetric window. Here is how you might use a Kaiser window to create a low-pass filter:

Examples

CopyC#
Const MAXKAISERWIN As Integer = 256
' Create non-recursive low-pass filter using Kaiser window
' freq      corner freq  (fraction of sampling rate)
' ripple    allowed ripple (dB)
' twidth    transition width  (fraction of sampling rate)
Public Function KaiserLowPass(ByVal freq As Double, ByVal ripple As Double, ByVal twidth As Double) As LTISystem

' get (half-)Kaiser window
Dim kwin As Waveform = Window.Kaiser(ripple, twidth, MAXKAISERWIN)
Dim nhalf As Integer = kwin.Count() - 1

' generate one half of coefficients from windowed sinc() function
Dim omega As Double = 2 * Math.PI * freq
   For i As Integer = 0 To nhalf
       kwin(i + 1) *= omega * sinc(i * omega) / Math.PI
   Next

' copy into LTI System
Dim lpfilt As New LTISystem(2 * nhalf, 0)
   lpfilt.a(nhalf) = kwin(1)
   For i As Integer = 1 To nhalf
       lpfilt.a(nhalf - i) = kwin(i + 1)
       lpfilt.a(nhalf + i) = kwin(i + 1)
   Next

   Return lpfilt
End Function

See Also

Window Class